Version 4.01 - Post your problem here

Listing issues addressed in beta version 4.01
Peter2150
Posts: 878
Joined: Wed Mar 28, 2007 2:46 am
Location: Washington DC

Post by Peter2150 » Wed Feb 13, 2013 5:16 pm

I gave 4.01 a shakedown cruise last night

System is WinXP Pro 32bit

Other Security software installed are Online Armor, Appguard, and NVT ExeRadar Pro.

Install type was an upgrade. (which went fine)

First thing that didn't work was printing to adobe Acrobat from Firefox. Error I got was activate adobe acrobat and try again. Retested later under 3.76 and it worked fine.

Most annoying thing was every time I started Firefox(17) I'd get an alert from Online Armor that a program I was running had changed. It was Shellex.dll(I think) trying to start Firefox. Got the pop up every time.

I tried disabling the HIPS part of OA, and something else broke, so at that point I rolled back the system.

Pete

MrCairo

Post by MrCairo » Thu Feb 14, 2013 1:25 pm

I have exactly the same error plus SbieSvc.exe is crashing like crazy. :)

Error: SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [00000102]

Firefox 18.0.2, WinXP SP3

This only happen if I set low priviledges.
I guess I'll rollback to v3.76 and wait for something more stable.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Post by tzuk » Thu Feb 14, 2013 8:22 pm

Thank you for continued feedback. I understand there are some issues with the first beta version 4, obviously. And I apologize about any inconvenience. The next beta will include several fixes that should improve things some what. I should be able to release it soon, at which point I would like to hear if it fixes some of these issues. Appreciate your patience! :)
tzuk

bo.elam
Sandboxie Guru
Sandboxie Guru
Posts: 2609
Joined: Thu Apr 23, 2009 2:17 am

Post by bo.elam » Fri Feb 22, 2013 3:33 am

Hey Tzuk, a few weeks ago I tried 4.01 8) in W7, tonight I tested it in XP SP3 32bits. The three programs I tried (Foxit, IE8 and KMPlayer) running sandboxed gave me the same message, SBIE 2203.

Bo

TBones
Posts: 2
Joined: Thu Jan 31, 2013 5:23 am

Post by TBones » Fri Feb 22, 2013 5:42 am

After Google Chrome updated itself to version 25, I received the following messages on my Windows 7 SP1 x64 machine:

SBIE2203 Failed to communicate with Sandboxie Service: connect C0000022
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]

mart
Posts: 74
Joined: Mon Sep 04, 2006 8:08 am
Location: England
Contact:

Post by mart » Fri Feb 22, 2013 7:36 am

Same messages here after Google Chrome updated to version 25. Windows 8 64-bit

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Post by tzuk » Fri Feb 22, 2013 10:46 am

Thanks. I see this occur even with the still-unreleased version 4.01.02 code. I will report back about this tomorrow.
tzuk

GWhite

Chrome errors

Post by GWhite » Sat Feb 23, 2013 4:18 pm

Same errors with Chrome 25 here...Windows 8 64 bit

SBIE2203 Failed to communicate with Sandboxie Service: connect C0000022
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [C0000080]

Tzuk,

I just wanted to thank you for writing such an awesome piece of software...those of us working in IT rarely seem to hears the kudos, just the problems.

GW

mart
Posts: 74
Joined: Mon Sep 04, 2006 8:08 am
Location: England
Contact:

Re: Chrome errors

Post by mart » Sun Feb 24, 2013 7:54 am

GWhite wrote:those of us working in IT rarely seem to hears the kudos, just the problems.
When it comes to discussing protection, Sandboxie and Tzuk are mentioned favourably quite a lot across the Internet.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Post by tzuk » Sun Feb 24, 2013 3:39 pm

Thanks mart.

I think I was able to fix the problems of these error messages with Chrome 25. I still get a one-time crash while installing Chrome 25 into a sandbox but it doesn't seem to interfere with running Chrome. And I think people who have Chrome installed outside the sandbox wouldn't see this in the first place.

Version 4.01.02 coming in a few days hopefully.
tzuk

Trespasser
Posts: 47
Joined: Thu Oct 04, 2007 9:19 pm

Post by Trespasser » Sun Feb 24, 2013 4:32 pm

Hi tzuk,
Hopefully version 4.0.1.02 fixes the problems I'm having with LibreOffice 4.0 (under 3.6.5, no problem at all). I can click on the LibreOffice icon, Sandboxie activates for one or two seconds then the delete icon appears and LibreOffice doesn't open. Yet if I click on an already saved docx file LibreOffice 4 opens it in a sandbox. Strange.

I'd also like to see printing from a 32 bit application, like Firefox, Chrome, or LibreOffice for example, on a 64 bit Win 8 system fixed as well.

I suspect that the problems that you are dealing with, and trying to over come, are far more formidable than we might imagine as evidenced by the time period between the release of 4.0.1 and now. But, you're brilliant, so, I wish you the best of ingenuity with it.

Kind regards from a loyal fan,

Bob

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Post by tzuk » Mon Feb 25, 2013 8:28 pm

Version 4.01.02 was released and you can check if it fixes the Chrome 25 problem.

Trespasser -- thanks. Haven't looked into your problem report yet, but please check if version 4.01.02 is an improvement. If not, please post a separate problem report topic with the details of your problem.

I will probably lock this topic in a couple of days because I prefer separate topics for separate problem reports, it makes it easier for me to track and post updates.
tzuk

DR_LaRRY_PEpPeR
Posts: 289
Joined: Wed Jul 04, 2012 11:40 pm
Location: St. Louis area

Post by DR_LaRRY_PEpPeR » Tue Feb 26, 2013 1:55 am

Before you lock this topic, I decided to check out the latest version quickly! So, to report (not complain :)), all of what I reported is still happening. I was hoping I might be able to "run stuff for real" and check it out further, but it's still unusable when I can't launch things as usual. :cry: I also noticed Drop Rights is worse than I thought (broken?)...
DR_LaRRY_PEpPeR wrote:Problems I found are mostly related to testing interaction with XP's SRP. First, when SRP is set to run a program as a Basic/Standard User (e.g. SRP dropping admin rights), and Run Sandboxed is invoked on it, the result is:

SBIE2205 Service not implemented: SetInformationProcess

I guess after Start.exe starts it, something preventing SRP applying restrictions... Of course, SRP was just ignored previously with Start.exe.

BTW, other SBIE2205 messages you might be aware of: Add Font, SetParent, and I think it was Add Icon or Load Icon a couple times that I can't reproduce now. (The icon IS missing on 1 SRP blocked alert box, although that's not where I got the SBIE2205.)


Enabling Drop Rights (regardless of any SRP stuff) and launching IE 6 crashes SbieSvc after the IE window is launched (but nothing else happens). Using Run Sandboxed or forced doesn't matter. No problem with Drop Rights on Notepad, Regedit, or Explorer (OH, unless a Web address is entered, so Internet related?).


Finally, there's a problem with registry permissions now. When a program has no admin rights (via SRP or Drop Rights), it can still access registry keys that ONLY have permissions for Administrators! (Files with the same scenario are fine, "Access Denied.") This is much worse than kinda the opposite problem I found with files and Drop Rights previously.
I notice I said "no admin rights (via SRP or Drop Rights)," but must not have checked each method with Explorer/IE (as Explorer, browsing C:\, etc.)/Regedit. I reverted to the initial 4.01 release and verified the same behavior in both:

When rights are dropped with SRP, ALL permissions seem to work correctly with what I checked.

But Sandboxie's Drop Rights appears to have no effect at all! Files with only Administrators permission can be read (e.g. boot.ini, no "Access is denied"), files/folders can be created/deleted in C:\ (using Direct Access of course, no "Access is denied"), and the aforementioned reg. keys with only Administrators permission can be read (no "Error opening key").
XP Home-as-Pro SP3 (Admin) w/ continued updates (Embedded/POSReady 2009)
> Permissions + "2-level" SRP, latest Sandboxie (Pro/registered), EMET 4, no anti-anything (ever)
Did I make tzuk crazed... in his last days? :o

zyx
Posts: 10
Joined: Sun Feb 26, 2012 2:13 pm

Post by zyx » Tue Feb 26, 2013 5:38 pm

I get following errors when trying to run anything in sandbox when launched via Standalonestack
SBIE2336 Error in GUI server: [11 / C0000021]
SBIE2335 Initialization failed for proccess asd.exe [88 / 0]
Using .02 and Win 7 x64

henri
Posts: 35
Joined: Thu Jan 03, 2013 8:51 pm

4.02 Problem with activaction persist

Post by henri » Tue Feb 26, 2013 7:02 pm

I can´t use version 4.02 because the problem persist; every time I logon in guest or administrative account (w7/32 or w8/x64 with dual boot or without) I need to activate license and this is irritant, otherwise everything seems ok for me in this moment.

Thanks.

Locked

Who is online

Users browsing this forum: No registered users and 0 guests