Firefox 56/57/58 sound/videos/printing not working when sandboxed [Fixed in beta 5.25.4]

Please post your problem description here

Moderator: Barb@Invincea

Nix
Posts: 248
Joined: Wed Sep 11, 2013 12:15 am
Location: Philippines

Sound Problem

Post by Nix » Sat Nov 25, 2017 9:56 pm

Hi Admin,


I'm having a bit of a problem with Firefox on windows 7, any video I'm playing doesn't have a sound when FF is inside SBIE outside no problem at all. But in my win1 x64 1709 laptop I don't have such issue, need you advice in this matter. Already reinstalled FF no such luck with the sound issue.

Regards,
Nix
Regards,
Nix

Win7 Ultimate (x64)

Image

bo.elam
Sandboxie Guru
Sandboxie Guru
Posts: 2826
Joined: Wed Apr 22, 2009 9:17 pm

Re: Sound Problem

Post by bo.elam » Sun Nov 26, 2017 1:09 am

Hi Nix

Try, Open about:config, change "security.sandbox.content.level" to 2 or 1 or 0.

If that don't work, try disabling Multiprocess, in about:config, change value to false: "browser.tabs.remote.autostart", make sure browser.tabs.remote.autostart.2 is also set to false-

Bo

Nix
Posts: 248
Joined: Wed Sep 11, 2013 12:15 am
Location: Philippines

Re: Sound Problem

Post by Nix » Sun Nov 26, 2017 6:42 am

Hi Bo,

"security.sandbox.content.level" to 2 works, didn't know FF already implemented a sandbox... been almost a year that I haven't used FF. Thanks!

Nix
Regards,
Nix

Win7 Ultimate (x64)

Image

Stardance
Posts: 78
Joined: Sun Dec 28, 2008 10:52 pm

Re: Firefox 56.0 sound not working when sandboxed

Post by Stardance » Wed Nov 29, 2017 6:17 pm

To recapitulate: currently I am running Sandboxie 5.22 on 64-bit Windows 7 Professional SP2 (fully updated). Firefox Quantum v. 57 ordinarily has not output any sound when it displays a video on a website page while Firefox is running sandboxed. While running without a Sandboxie sandbox, Firefox has functioned as expected. (I run Microsoft Security Essentials as the "anti-virus".)

With regard to Firefox Quantum v. 57 settings and configuration:

(1) For the Options Performance preferences: If I enable "recommended settings", then Hardware Acceleration is enabled, and the Content Process Limit is 1 (default) unless I increase it -- there is no "0" option.

Disenabling Hardware Acceleration makes no difference. The comment about the Content Process Limit is "Additional content processes can improve performance when using multiple tabs, but will also use more memory." Since there is 16 GB of system memory on this rig, increasing it shouldn't cause a problem.

(2) Reducing the about:config setting for security.sandbox.content.level to zero makes no difference, nor did reducing it to a value of 1 or of 2 from the initial value of 3.

(3) The about:config setting for browser.tabs.remote.autostart was already set to false. I toggled browser.tabs.remote.autostart2 to false also. Doing that has not resolved the problem.

(4) Note: currently the Firefox NoScript 10.1 add-on is configured to "Scripts Globally Allowed" because there have been problems with using it the way that I have customarily used it before. But there aren't any problems when I use that setting, as undesirable and risky as it is. There also seem to be some hidden Firefox Quantum "security" setting(s) that attempt to control website usage of JavaScript, but I haven't had an opportunity to investigate that aspect of the issue.

THUS FAR:

(A) Sandboxed Firebox Quantum does not display video with sound for https://www.youtube.com, for https://www.msn.com/?cp=p:news, or for any video shown on https://www.facebook.com/ (including video on the pages of various and sundry websites to which Newsfeed items link). Frankly, though, apparently Facebook either has other problems with Firefox Quantum or problems of their own with the website, or probably both.

(B) Currently, sandboxed Firefox Quantum displays video with sound for http://www.msnbc.com/ as anyone would expect. However, I haven't tested it with each of the respective changes (above) so I don't know whether it would not have worked previously.

FYI: following is the configuration for the sandbox in which Sandboxie runs Firefox Quantum v. 57, preceded by Global Settings and definitions of Templates:

Code: Select all

[GlobalSettings]

ActivationPrompt=n
Template=nVidia_Stereoscopic3D
Template=Logitech_G15_Keyboard
Template=OfficeLicensing
Template=Microsoft_Security_Essentials
Template=Microsoft_MSMQ
Template=LastPass
TemplateReject=WindowsLive
TemplateReject=KeyScrambler
ForceDisableSeconds=10

[TemplateSettings]

Template=LastPass

[Template_Local_Secure_Directories]

Tmpl.Title=Local Secure Directories
Tmpl.Class=WebBrowser
ClosedFilePath=!firefox.exe,%Local AppData%\Mozilla\Firefox
ClosedFilePath=!firefox.exe,%AppData%\Mozilla\Firefox
ClosedFilePath=!iexplore.exe,%Favorites%
ClosedFilePath=!iexplore.exe,%Cookies%
ClosedFilePath=!chrome.exe,googleupdate.exe,%Local AppData%\Google\Chrome
ClosedFilePath=!chrome.exe,googleupdate.exe,%AppData%\Google\Chrome
ClosedFilePath=!wmplayer.exe,C:\Program Files\Windows Media Player\

[Template_Local_AutoIgnore_Directories]

Tmpl.Title=Local AutoIgnore Directories
Tmpl.Class=WebBrowser
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Roaming\Microsoft\Windows\Recent
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Roaming\Microsoft\Windows\Temporary Internet Files
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Local\Temp
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Roaming\Adobe\FlashPlayer
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Roaming\Adobe\Macromedia
AutoRecoverIgnore=C:\Users\SYSOP\AppData\Roaming\Macromedia

[Template_Local_Recover_Folders]

Tmpl.Title=Local Recover Folders
Tmpl.Class=WebBrowser
RecoverFolder=C:\ProgramData
RecoverFolder=C:\Users\SYSOP\Downloads
RecoverFolder=C:\Users\SYSOP\AppData
RecoverFolder=C:\TEMP
RecoverFolder=C:\WINDOWS
RecoverFolder=F:\AGAPE
RecoverFolder=F:\BACKUPS
RecoverFolder=F:\COMPUTER
RecoverFolder=F:\DNL
RecoverFolder=F:\GAMES
RecoverFolder=F:\GAMES\Alan Wake (Remedy)
RecoverFolder=F:\GAMES\World of Warcraft (Blizzard)
RecoverFolder=F:\GAMES\The Elder Scrolls Online (Zenimax)
RecoverFolder=F:\GAMES\The Elder Scrolls V - Skyrim (Bethesda)
RecoverFolder=F:\GAMES\HUMBLE BUNDLES
RecoverFolder=F:\INSTALL
RecoverFolder=F:\INSTALLERS
RecoverFolder=F:\LIVING
RecoverFolder=F:\LIBRARY
RecoverFolder=F:\MEDIA
RecoverFolder=F:\NOTES
RecoverFolder=F:\Program Data
RecoverFolder=F:\ProgramData
RecoverFolder=F:\Program Files
RecoverFolder=F:\Program Files (x86)
RecoverFolder=F:\SCRAPBOOK
RecoverFolder=F:\SCREENSHOTS
RecoverFolder=F:\SNAPSHOTS
RecoverFolder=F:\TEMP
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%AppData%\Mozilla\Firefox\Crash Reports
RecoverFolder=%AppData%\Mozilla\Firefox\Profiles\extensions
RecoverFolder=%Favorites%
RecoverFolder=%Cookies%
RecoverFolder=%Personal%
RecoverFolder=%Desktop%

[Firebox]

Enabled=y
BoxNameTitle=y
BorderColor=#00FFFF,ttl
ConfigLevel=7
DropAdminRights=n
ForceProcess=firefox.exe
NotifyInternetAccessDenied=y
NotifyStartRunAccessDenied=y
CopyLimitKb=128000
Template=Firefox_Cookies_DirectAccess
Template=Firefox_Session_DirectAccess
Template=Firefox_Bookmarks_DirectAccess
Template=Firefox_Profile_DirectAccess
Template=Firefox_Phishing_DirectAccess
Template=LastPass
Template=Local_Secure_Directories
Template=Local_AutoIgnore_Directories
Template=Local_Recover_Folders
Template=AutoRecoverIgnore
Template=BlockPorts
Template=LingerPrograms
OpenProtectedStorage=y
OpenCredentials=y
ClosedFilePath=!<InternetAccess>,InternetAccessDevices
ClosedFilePath=D:\
ClosedFilePath=E:\
ClosedFilePath=!firefox.exe,F:\
ClosedFilePath=*\GEARAspiWDMDevice*
OpenFilePath=firefox.exe,%Local AppData%\Mozilla\Firefox\
OpenFilePath=firefox.exe,%AppData%\Mozilla\Firefox\Crash Reports\
OpenFilePath=wmplayer.exe,C:\Program Files\Windows Media Player\
OpenFilePath=WerFault.exe,C:\Users\SYSOP\AppData\Local\
OpenFilePath=F:\DNL\
OpenFilePath=F:\GAMES\
OpenFilePath=F:\INSTALL\
OpenFilePath=F:\LIBRARY\
OpenFilePath=F:\MEDIA\
OpenFilePath=F:\SCREENSHOTS\
ReadFilePath=C:\WINDOWS
ReadFilePath=G:\
LingerProcess=firefox.exe
LingerProcess=wuauclt.exe
LingerProcess=rundll.exe
LeaderProcess=<FirefoxPrograms>
AutoRecover=y
AutoDelete=y
NeverDelete=n
ProcessGroup=<InternetAccess>,firefox.exe,plugin-container.exe,updater.exe,xpicleanup.exe,xpicle~1.exe,crashreporter.exe,crashr~1.exe,iedw.exe,container.exe,icwconn1.exe,icwconn2.exe,icwrmind.exe,icwtutor.exe,inetwiz.exe,isignup.exe,wuauclt.exe,jqsnotify.exe,dwwin.exe,SandboxieBITS.exe,SandboxieCrypto.exe,SandboxieDcomLaunch.exe,SandboxieEventSys.exe,SandboxieWUAU.exe,SWDNLD.EXE,SwHelper_1205146.exe,xpnetdiag.exe,wmplayer.exe,Foxit Reader.exe,Foxit Updater.exe,GenuineCheck.exe,dllhost.exe,WerFault.exe,java.exe,setup_wm.exe,BitTorrent.exe,notepad++.exe,DNTPService.exe,SwHelper_1214154.exe,wermgr.exe,FlashPlayerPlugin_26_0_0_137.exe,explorer.exe
Thank you for your time and attention to this issue.
|
| Stardance
|
| nil carborundum illegitimi!

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2470
Joined: Mon Nov 07, 2016 3:10 pm

Re: Firefox 56/57 sound not working when sandboxed

Post by Barb@Invincea » Thu Nov 30, 2017 10:15 am

Hello Stardance,

Have you performed the steps outside Sandboxie? If not, please do that and then delete the contents of your sandbox to re-try.

If the issue still persists, create a new Sandbox with default settings and let us know if the problem follows you there.

If all fails, please create a new Firefox profile, make sure that the sandbox content level is set to 2 or lower, and if needed disable multiprocess (browser.tabs.remote... ). Then re-try using Firefox to play videos inside Sandboxie.

Regards,
Barb.-

DrAlrek
Posts: 4
Joined: Wed Mar 18, 2015 11:37 pm
Location: I use a VPN for a reason -_-
Contact:

Re: Firefox 56/57 sound not working when sandboxed

Post by DrAlrek » Sun Dec 10, 2017 5:32 pm

I found a work-around for this problem.

(Sandbox settings for the sandboxes that you use firefox in)>restrictions>drop rights> tick the setting to deny admin rights to apps running inside sandboxie. Then sound SHOULD start playing in firefox again, at least it did for me.

I run windows 7 home premium with all updates (and a lot of the optional updates) I used GWX control panel to disable windows 10 updates. I have the latest stable build of firefox and the latest stable build of sandboxie and I run Comodo I.S. along side sandboxie with it set to auto-block all of the unknown and auto-quarantine the known bad.

I hope this work-around helps. I personally find it better to run sandboxed programs without admin privileges, that way if there's ransomware that gets loaded through an exploit kit in a banner ad or something, the ransomware almost always gets stopped by just sandboxie, because it gets denied admin access
Sandboxie (lifetime-user)(Duh)
Zemana A.M. (was a beta tester)
VoodooShield (paid)
Comodo Firewall set to auto-block the unknown
A VPN that I'd rather not name

Stardance
Posts: 78
Joined: Sun Dec 28, 2008 10:52 pm

Re: Firefox 56/57 sound not working when sandboxed

Post by Stardance » Tue Jan 02, 2018 4:56 pm

To whom it may concern: eventually everything started working as expected, for no apparent reason.

I have no idea as to which specific measure(s) that I took to resolve this problem, and a couple of others with Firefox Quantum v. 57, that might have been responsible for the change. They did not change anything immediately or after restarting Firefox at the time. Firefox has since been updated to 57.0.1 and again to 57.0.2 and it still works as expected.

In my prior experience with Firefox, changes made with about:config often do not survive an update, especially when the major version number increments. Sometimes a setting which I changed (or introduced, upon expert advice) no longer exists ("deprecated"). But most often it is simply re-set to the current default for that version. So there is no guarantee that whatever caused this problem will not recurr in the future. On the other hand, re-setting a configuration option to the default in a future version might not cause any problems.

That said, thank you all very much for your time, attention, and advice in resolving this and other problems that occurred after the upgrade to Firefox Quantum.
|
| Stardance
|
| nil carborundum illegitimi!

Peter 123
Posts: 90
Joined: Sun Jun 23, 2013 10:48 am

No sound in YouTube with Firefox 58.0.1

Post by Peter 123 » Tue Jan 30, 2018 10:58 am

Just a quick report:

After updating Firefox to the latest version 58.0.1 the sound in YouTube does not work any longer.

Outside of the sandbox the sound in YouTube is o.k.

Windows 7 Home Premium, 32 bit
Sandboxie version 5.22
Windows 7 Home Premium 32 bit, Microsoft Security Essentials, Windows Firewall, Firefox

APMichael
Posts: 160
Joined: Sun Sep 07, 2014 5:54 am
Location: Germany

Re: No sound in YouTube with Firefox 58.0.1

Post by APMichael » Tue Jan 30, 2018 11:51 am

Barb@Invincea wrote:
Tue Aug 29, 2017 1:39 pm
Open Firefox outside Sandboxie
type about:config and accept the risk
search sandbox
Switch security.sandbox.content.level to 2 (mine was 3, if needed switch it to 1 or 0 ).
Close Firefox
Relaunch it Sandboxed...
If that doesn't work, please check this thread: viewtopic.php?f=11&t=25364&p=132002&hil ... nd#p132002

Peter 123
Posts: 90
Joined: Sun Jun 23, 2013 10:48 am

Re: Firefox 56/57/58 sound not working when sandboxed

Post by Peter 123 » Tue Jan 30, 2018 4:43 pm

Thank you, APMichael, for your reply and thank you, Barb, for the advice.

Yes, indeed, the sound in Youtube is back when switching the value for "security.sandbox.content.level" from 4 (as it was in my case) to 2. :D

Alternatively, the method described by bo.elam and Geordy in the other thread works also for me: changing the value for "browser.tabs.remote.autostart" from "true" to "false". (Perhaps that's the "softer" method as it does not influence the security level given as default by Firefox.) - Thanks to both of you too. :D
Windows 7 Home Premium 32 bit, Microsoft Security Essentials, Windows Firewall, Firefox

Webfra
Posts: 1
Joined: Wed Nov 12, 2014 12:55 pm

Re: Firefox 56/57/58 sound not working when sandboxed

Post by Webfra » Mon Feb 05, 2018 1:39 pm

Hi All,

I had the same problem, enabling the following setting helped:
media.useAudioChannelAPI modified boolean true

I don't know what it does, but at least it really seems to be related to "audio" ...

Update: Just checked, I also have security.sandbox.content.level = 2, (and 4 doesn't work) so I guess both settings are needed...

Greets,
Webfra

VanessaF
Posts: 1
Joined: Sun Feb 11, 2018 1:20 pm

Re: Firefox 56/57/58 sound not working when sandboxed

Post by VanessaF » Sat Feb 17, 2018 11:58 am

Hi guys,

I have the same problem. I tried the following:
- security.sandbox.content.level to 2
- media.useAudioChannelAPI modified boolean true
- browser.tabs.remote.autostart --> false
- browser.tabs.remote.autostart.2 --> false

Unfortunately nothing changed and the problem still exists. One think that I noticed is that if I watch the video in a sandboxed Firefox it does not start immediatley. You have to wait some 5 seconds for the video to start but you see the first picture of the video immediately. But if you use Firefox without sandboxie the video (and sound) starts automatically. Does anyone have a suggestion?

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2470
Joined: Mon Nov 07, 2016 3:10 pm

Re: Firefox 56/57/58 sound not working when sandboxed

Post by Barb@Invincea » Tue Feb 20, 2018 11:19 am

Hello VanessaF,

Did you ensure the changes were made outside sandboxed Firefox, and that they are still there after relaunching Firefox (non sandboxed)? If so have you tried, after making the changes, to launch Firefox in a new Sandbox with default settings?
Please re-try, starting withe the Sandbox content level settings (outside sandboxie), and if that fails, do the multiprocess (remote tabs), and if needed, the audio channel changes.

If the issue persists, please provide the required information so that I can test it:
viewtopic.php?f=11&t=19746

Regards,
Barb.-

rodalsa
Posts: 12
Joined: Tue Apr 08, 2014 7:59 am

Re: Firefox 56/57/58 sound not working when sandboxed

Post by rodalsa » Sat Feb 24, 2018 5:55 pm

I had the same problem.
Windows 7 Pro
Firefox 58.0.2 (64-Bit)
Sandboxie 5.22 (64-Bit)

Firefox was running stand alone for the fix.

I had only to change the Firefox setting under the URL entry about:config
From> browser.tabs.remote.autostart Default | boolean | true
To> browser.tabs.remote.autostart Modified | boolean | false
By using the right-click menu's Toggle choice.

I got my sound back in both configurations:
Firefox stand alone
Firefox hosted by Sandboxie. :D

The setting "security.sandbox.content.level" discussed as 2, 3 or 4 was 4 for my system. I did not change it.

henryg
Posts: 531
Joined: Wed Nov 22, 2006 9:38 am

Firefox & security.sandbox.content.level

Post by henryg » Fri Mar 16, 2018 5:00 am

Is it still necessary to reduce the security.sandbox.content.level to 2 to stop various problems inc pdf printing?

Windows 10x64 fully updated; Firefox 60b3; SB 5.24
Henry

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 16 guests