4.09 Beta Available (Latest Version 4.10 Release Candidate)

Listing issues addressed in beta version 4.09
kjdemuth
Posts: 13
Joined: Mon Oct 21, 2013 1:57 am

Re: 4.09 Beta Available (Latest Version 4.09.3)

Post by kjdemuth » Tue Apr 15, 2014 5:09 pm

Sorry that was the first run on Win 8.1 64 bit Firefox 28. I did have WSA for AV along with Adblock plus and lastpass for extensions. On repeat I haven't received that error again. I'll let you know if I can reproduce it or comes back again. At the moment everything is working well on firefox except Yahoo mail. I already posted in the problems section. Also I have adobe flash running with the protected mode disabled. I was having trouble initially with firefox hanging and have left it disabled since then.

joohwan@invincea
Posts: 87
Joined: Mon Feb 10, 2014 10:33 pm

Re: 4.09 Beta Available (Latest Version 4.09.3)

Post by joohwan@invincea » Tue Apr 15, 2014 7:00 pm

kjdemuth,

Thx for the update; when I get a free moment, I'll take a look at the Firefox 28 + Yahoo Mail thread.

kjdemuth
Posts: 13
Joined: Mon Oct 21, 2013 1:57 am

Re: 4.09 Beta Available (Latest Version 4.09.3)

Post by kjdemuth » Tue Apr 15, 2014 8:05 pm

Thanks. Just as a side note, Yahoo basic works. Yahoo basic doesn't have any of the animation and jazz. So it must have to be something related to flash script maybe.

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1600
Joined: Fri Jan 17, 2014 11:21 pm
Contact:

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by Curt@invincea » Thu Apr 17, 2014 4:23 am

4.9.4 available.
Fixed the following startup errors on the Dell Venue and other Win 8.1 tablets.
SBIE2336 Error in GUI server: [11 / C0000021]
SBIE2335 Initialization failed for process Start.exe [88/0]

Nix
Posts: 241
Joined: Wed Sep 11, 2013 5:15 am
Location: Philippines

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by Nix » Thu Apr 17, 2014 7:55 am

Thanks for the latest Beta...

When can we expect the release of 4.10?!

superkryo
Posts: 31
Joined: Mon Dec 27, 2010 4:48 pm

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by superkryo » Thu Apr 17, 2014 12:56 pm

Curt@invincea wrote:4.9.4 available.
Fixed the following startup errors on the Dell Venue and other Win 8.1 tablets.
SBIE2336 Error in GUI server: [11 / C0000021]
SBIE2335 Initialization failed for process Start.exe [88/0]
Have had this problem with matlab (http://www.mathworks.com) since version 4 on win7x64. No GUI server error in recent versions, but matlab.exe (which loads the main app gui) fails with sbie2335. Problem remains with 4.9.4

scottls59901
Posts: 186
Joined: Wed Jul 02, 2008 8:40 pm
Location: Kalispell, Montana USA

Re: 4.09 Beta Available (Latest Version 4.09.1)

Post by scottls59901 » Fri Apr 18, 2014 7:44 pm

Buster wrote:Thanks for the info!

I thought the changes made to internal architecture caused that Sandboxie was not suitable for malware analysis anymore, but it could be possible that the bug you fixed in 4.09.01 was in fact the reason that caused some malwares to do not run properly.

The question is I do not remember with what exact malware I noticed something was wrong with Sandboxie 4.x but I just made a small test with a malware sample set and analyses seem to be fine, just like the ones created with version 3.76.

So the good news for BSA users is that very probably Sandboxie 4.09.01+ versions will be suitable for doing malware analysis.

In order to improve Sandboxie´s stealthness I requested Ronen a feature. May I rescue the feature request and send it to you?


My KIS2013 AV forum recommends Uninstalling All veresions of sbie Before installing, then reinstall afterwards!-
You may have to uninstall your AV/sbie, and reinstall?

Buster
Posts: 2576
Joined: Mon Aug 06, 2007 7:38 pm
Contact:

Re: 4.09 Beta Available (Latest Version 4.09.1)

Post by Buster » Fri Apr 18, 2014 8:01 pm

scottls59901 wrote:My KIS2013 AV forum recommends Uninstalling All veresions of sbie Before installing, then reinstall afterwards!- You may have to uninstall your AV/sbie, and reinstall?
The problem was completely related to a bug Ronen introduced in Sandboxie version 4. So BSA can be used with version 3.76 or with version 4.9.1+

loyal
Posts: 7
Joined: Mon Mar 31, 2014 6:27 am

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by loyal » Mon Apr 21, 2014 8:14 pm

SBIE2336 Error ...PLS SOLVE IT

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1600
Joined: Fri Jan 17, 2014 11:21 pm
Contact:

Re: 4.09 Beta Available (Latest Version 4.09.3)

Post by Curt@invincea » Mon Apr 21, 2014 8:52 pm

kjdemuth wrote:Ok this is what I get when I use 4.9.3 with Firefox 28.

SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [C0000061]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [C0000061]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [C0000061]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [C0000061]
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - firefox.exe [C0000061]

The loop keeps continuing till I terminate the sandbox. I'm running sandbox with no restriction and no drop my rights. The only thing forced is Firefox. I'm running Win 8.1 64 bit.
In another thread, you mentioned that you had Webroot. Does this thread apply? http://forums.sandboxie.com/phpBB3/view ... t=C0000061

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1600
Joined: Fri Jan 17, 2014 11:21 pm
Contact:

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by Curt@invincea » Mon Apr 21, 2014 8:53 pm

loyal wrote:SBIE2336 Error ...PLS SOLVE IT
This is fixed in 4.9.4. Are you saying you are still getting this error?

kjdemuth
Posts: 13
Joined: Mon Oct 21, 2013 1:57 am

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by kjdemuth » Tue Apr 22, 2014 12:19 am

Curt it seems to be working with Webroot. The only thing that I'm still having an issue with is Flash protected mode. With it enabled it locks up certain sites like Yahoo mail and Live mail.

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1600
Joined: Fri Jan 17, 2014 11:21 pm
Contact:

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by Curt@invincea » Wed Apr 23, 2014 7:45 pm

Nix wrote:Thanks for the latest Beta...

When can we expect the release of 4.10?!
We are pushing back 4.10 for a couple of weeks. Instead, we are working on beta 4.9.5 which will be built with updated Microsoft compiler & linker. DEP (http://windows.microsoft.com/en-us/wind ... -questions) and ASLR (http://en.wikipedia.org/wiki/Address_sp ... domization) will be enabled. Some other misc. issues seem to have disappeared (more on those later). We are planning to release 4.9.5 before the end of the month.

DR_LaRRY_PEpPeR
Posts: 291
Joined: Wed Jul 04, 2012 11:40 pm
Location: St. Louis area

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by DR_LaRRY_PEpPeR » Wed Apr 23, 2014 7:54 pm

Modern compiler/linker?! Wow, yippee! (Imagine excited smilies here since they're disabled... :-/)

Fixed some other things as well with that change? Interesting, and look forward to hearing more. :-)

loyal
Posts: 7
Joined: Mon Mar 31, 2014 6:27 am

Re: 4.09 Beta Available (Latest Version 4.09.4)

Post by loyal » Wed Apr 23, 2014 9:07 pm

eRROR IN LATEST VERSION 4.09.4
SBIE2205 Service not implemented: NtCreateProcessEx (6704)
SBIE2205 Service not implemented: NtCreateProcessEx (6704)
SBIE2205 Service not implemented: NtCreateProcessEx (6704)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest