[.02] Unable to paste images into some sandboxed programs

Listing issues addressed in beta version 4.07
Locked
Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

[.02] Unable to paste images into some sandboxed programs

Post by Scoox » Wed Oct 16, 2013 8:57 pm

Windows 7 32-bit
Sandboxie v4.06
AliIM 2013Beta2 (7.09.01M) (download website, click blue button)

(I am running all latest versions.)

I recently started seen some problems with IM chat application "AliIM". Although you may never have heard of this program, it actually has a huge user base: it is the second most-used instant messaging software in mainland China after Tencent QQ, and it is used by every single Taobao (Chinese eBay) seller and buyer to communicate with each other.

1) The problem is that, while I can paste text, I cannot paste images, such as screen captures, into AliIM since Sandboxie v4.xx. After reverting to Sandboxie v3.76 I am able to paste images again.

2) Another possibly related problem occurs when copying Chinese characters from inside AliIM. The clipboard viewer reveals that every Chinese character has been copied as a question mark. This problem happens with Sandboxie v3.76 too, so it could easily be a bug in AliIM.

3) Probably unrelated, but when I launch AliIM I do get the following warning, although I seem to get it just as well with v3.76:

Image

Thank you!

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Fri Oct 18, 2013 6:04 am

Let's see if a simpler program exhibits the same problem. If you run wordpad.exe in the sandbox, are you able to paste images?
tzuk

Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

Post by Scoox » Fri Oct 18, 2013 8:10 am

Thanks for your reply.

I have just tested with Wordpad and had no problem pasting images. In addition, all other apps I regularly run in the same sandbox as AliIM don't exhibit this problem either, only AliIM does.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sat Oct 19, 2013 12:50 pm

I think it might be difficult to look into this problem specifically in the context of AliIM because (a) it's Chinese language software, I imagine, and (b) I don't have an account in the service. Perhaps you could still find some other program that shows the same problem?
tzuk

Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

Post by Scoox » Wed Oct 30, 2013 10:27 pm

Unfortunately I haven't found another app where this happens, but if you are happy to test, I have just created an account and added myself as a contact so that you are able to open a chat window, which is where screenshots are pasted. I have just PMed you screenshots showing basic operation of the software and login credentials, and a link to download the whole sandbox directory where the software is pre-installed, as well as sandboxie.ini.

The file you need to run is this: C:\Sandbox\Manuel\DefaultBox\drive\C\Program Files\AliWangWang\AliIM.exe

You will get logged in automatically as I've set the app to remember the login credentials. Thank you!

Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

Post by Scoox » Thu Oct 31, 2013 12:00 am

I just tried to PM you but every time I click "Return to Inbox" I get a warning message telling me to wait before sending another PM, so I think there's a bug in the forum, so I am not sure the PM got sent. Consequently I am just going to post it here.

Hi tzuk, this PM is regarding the issue I reported in this thread.

(NOTE: I am sending this for the 3rd time because the system kept telling me to wait 10 minutes, if you got this email several times please accept my apologies)

AliIM login credentials:

UN: sandboxie_test
PW: happytesting

Basic operation screenshots:

Image
Image

You can download the sandbox here:

https://dl.dropboxusercontent.com/u/986 ... esting.rar[/img]

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Oct 31, 2013 4:00 pm

Thanks for setting this up Scoox. I'll try to look into this next week.
tzuk

Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

Post by Scoox » Tue Nov 05, 2013 2:38 am

Nice one! Sorry I take so long to reply each time. My email service provider (gmx) is blocked in China so I have to actively go through hoops to get my email.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Nov 06, 2013 6:04 am

Please check if version 4.07.02 fixes the problem with pasting an image.

http://www.sandboxie.com/phpbb/viewtopic.php?t=16838
tzuk

Scoox
Posts: 92
Joined: Sat Dec 04, 2010 10:45 am

Post by Scoox » Sat Dec 21, 2013 3:53 am

Sorry for the late reply, GMX email is blocked where I live... welcome to China.

Just tested version 4.07.05 and I am able to copy/paste images into and from AliIM. Thank you Tzuk!

Did you find any oddities regarding issue 2) in this thread's opening post, whereby Asian script characters (Chinese in this case) are incorrectly copied out of AliIM and shown as question marks in the clipboard viewer? Looks like a character encoding issue, and it's not necessarily an SB bug. I will check on a friend's computer where AliIM is run un-sandboxed on an English version of Windows 7, will post back my findings.

Thanks again for this update(s), they are really useful :)

lwc
Posts: 334
Joined: Tue Dec 19, 2006 6:37 am

Post by lwc » Thu Jan 23, 2014 7:44 pm

4.08
Added support for pasting bitmaps and metafiles from the clipboard.
What a weird phrasing of this feature. Shouldn't it be "Improved" support instead of "Added"?

Anyway, I wonder what was the specific issue regarding pasting into AliIM.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest