Page 1 of 1

[.02] Copy/Paste Suggestion

Posted: Sun Jul 21, 2013 6:39 pm
by 0strodamus
I was wondering if the changes that were made to Sandboxie 4.03.01 beta and later to address copy/paste issues could be made into an optional configuration item. I've already posted regarding issues with copying and pasting that I experienced for the first time starting with 4.03.01. I thought I could live with it, but had no idea how much copying and pasting that I actually do. It was maddening. I reverted back to release version 4.02 and have not had an issue since. I know the problem is related to my use of CLCL and there isn't any way to fix it. However, for me at least, it wasn't broken until version 4.03.01. Would you please consider adding a new Software Compatibility or other setting that could revert the changes made to 4.03.01+ regarding copy/paste if needed for users in my situation?

Posted: Mon Jul 22, 2013 4:11 am
by tzuk
I don't think you emphasized the point that things were working well for you before version 4.03.
I just assumed that copy/paste did not work at all because that was the common problem at the time.

Let's try something, please open Windows Task Manager and right-click on the CLCL.EXE process
and then select Set Priority > Low and let's see if that is one way to fix the problem for you.

Posted: Mon Jul 22, 2013 3:04 pm
by 0strodamus
I should have been more clear in my first post. Sorry about that.

Prior to posting this time and going back to release version 4.02, I had already tried lowering the CLCL.exe process priority without success. I noticed you recommended that to another user and hoped it would work for me, but it didn't.

I can imagine this must be frustrating for you when the changes you made to 4.03 fixed some (probably most) user's copy/paste problems, but broke others. That's why I was wondering if it is some behavior that could be toggled. Thanks for the reply and suggestion, I appreciate it. If there's anything else I can try, let me know.

Posted: Tue Jul 23, 2013 3:12 am
by tzuk
I just noticed that in a particular scenario, where every other copy command that I issued was just ignored.
By this I mean: Clicked Copy once, nothing happens, and the clipboard is still the same. Clicked Copy twice, now it copies.
The next Copy command again does nothing, and the one after that works, and so on.
Is this the behavior that you were seeing with version 4.03.01 ?

Posted: Tue Jul 23, 2013 9:40 pm
by 0strodamus
The behavior you describe sounds very familiar. I do know that if I copied repeatedly, it would eventually make it onto the clipboard. I don't recall if it was consistently twice. I would click Copy (or press Ctrl-C), then my hotkey for CLCL - see that nothing had copied and repeat the process until what I was copying made it to the clipboard. I could reinstall 4.03.01 and test again while paying closer attention if you would like me to.

Posted: Wed Jul 24, 2013 10:29 am
by tzuk
Are you talking about copying text or copying files? I am testing with CLCL and copying text seems to always work and not cause any problem. But when I copy files, sometimes they don't make it to the CLCL and the clipboard.

Posted: Wed Jul 24, 2013 2:03 pm
by 0strodamus
For me, it was always when copying text. I rarely copy any objects or files from the Sandbox.

Here's another thing that I observed. This happened rarely to me, but perhaps it is related to the file copying issue that you're seeing. Sometimes in CLCL, instead of showing the actual text on the clipboard, it would show that there was a text object (displayed as (TEXT) in light blue). When that would happen, I could never get any text to copy from Sandboxie no matter how many Ctrl-C operations I performed. When that would happen, I would have to reset the Windows clipboard by running "cmd cmd /c "echo off | clip"" as administrator (I learned that trick from another forum). After running the command, I could copy text, but with all of the issues we've already discussed. Those problems never went away completely no matter what I tried.

Thanks for staying with this and I hope an answer comes soon so you can move on to other things. I do really do appreciate the support. You and your program are the best!

Posted: Wed Jul 24, 2013 3:17 pm
by tzuk
And thank you for your patience! Tell me please, did you see these copy/paste problems across all programs in the sandbox? If you saw them primarily in a web browser, which one was it?

Posted: Wed Jul 24, 2013 7:14 pm
by 0strodamus
Firefox is the only program I run sandboxed. The Firefox version is 22. I don't know if it matters, but I probably should have mentioned that this is on Windows 7 SP1 x64. Also, I've been using Sandboxie 4.02 for a couple days now and it hasn't had a single copy issue.

Posted: Thu Jul 25, 2013 9:16 am
by tzuk
I tweaked the clipboard handling logic in Sandboxie a bit in version 4.05.02. Would like to hear if it fixes the problem for you. And hopefully doesn't break it for other people. :)

Posted: Thu Jul 25, 2013 11:37 am
by 0strodamus
Thanks for the new version! I can't wait to try it. Unfortunately, it will be a few days. I'll post back as soon as I can and I also hope it doesn't break it for others.

Posted: Sun Jul 28, 2013 1:06 am
by 0strodamus
I was able to test 4.05.02 for the past few hours. Try as I might to break copy/paste, I utterly failed. The clipboard handling logic that you tweaked worked! Thank you so much! :D

Posted: Sun Jul 28, 2013 3:04 am
by tzuk
My pleasure. Glad to see the good news. :)