[.09] Support for Windows Server 2003

Listing issues addressed in beta version 4.05
peraphon
Posts: 1
Joined: Thu Jul 18, 2013 5:04 am

[.09] Support for Windows Server 2003

Post by peraphon » Thu Jul 18, 2013 5:11 am

Upgraded to Sandboxie 4.04 from 3.74 on Windows Server 2003 SP2 32-bit

Attempted to run Firefox Portable v17.0.1 and got a SBIE1222 error saying that there was an error removing a security token.

Not sure of whether or not other software was affected - I only run my web browser in sandboxes.

Downgraded to 3.76, problem solved.

This happened in a brand new sandbox as well as in the old sandboxes.

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

SBIE1222 error

Post by jassing » Tue Aug 27, 2013 11:34 am

Yes, I tried the latest (as of today, 27 Aug 2013) beta.

Sadly, I just got the same thing. An uninstall & re-install didn't help. looks like sandboxie doesn't work with win2003 anymore...SBIE1222 error. I get it for anything I try to launch. It's actually complaining about sandboxie's 'start.exe'. I have no active scanners on this computer.

Did you figure anything out?

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Aug 28, 2013 2:43 am

It is possible version 4 is not compatible with Windows 2003.

You can download version 3.76 here:

http://www.sandboxie.com/index.php?AllVersions
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Wed Aug 28, 2013 5:42 pm

So that's it? It's a shame if that is the case, "good bye win2003 users"

I work for a company that sells software all over the world. based on feedback we get, win2003 is still widely used.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Aug 29, 2013 4:32 am

If this is the 32-bit Windows 2003 Server, you can send me a copy of your NTOSKRNL.EXE file,
and I will try to make the necessary adjustments in Sandboxie for the next beta build.
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Thu Aug 29, 2013 10:55 am

PM sent with link to file for download;

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Aug 29, 2013 2:31 pm

Got it, thanks. I will look at it in a couple of days and will ask you to test the next beta version when I release it some time next week.
tzuk

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Mon Sep 02, 2013 9:52 am

Please let me know if version 4.05.08 works better with Windows Server 2003.

http://www.sandboxie.com/phpbb/viewtopic.php?t=16079
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Mon Sep 02, 2013 11:30 am

No better:

SBIE1222 Error with security token: [C0000058 / 62]
SBIE1222 Error with security token: [C0000022 / 61]
SBIE2314 Canceling process Start.exe

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Mon Sep 02, 2013 2:42 pm

Looks like I missed some of the places that need adjustment. Please try this then:

http://www.sandboxie.com/SandboxieInsta ... 8-W2K3.exe
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Tue Sep 03, 2013 10:16 am

Looks like we're getting better...
When I do "run any program" (or anything, really) I get this single line error:

Code: Select all

SBIE2204 Cannot start sandboxed service RpcSs (128)
Start.exe is shown as running in the sandboxie UI.

Repeat, and same result (now two start.exe's running)
Image
I thought this was a little odd (two sets of the service running)

So I stopped the service, killed all instances of start.exe (the other exe's were no longer running)
Restarted the service, and tried to run again:

Code: Select all

SBIE2336 Error in GUI server:  [63 / 00000008]
SBIE2336 Error in GUI server:  [22 / 77000001]
SBIE2335 Initialization failed for process Start.exe [88 / 0]
SBIE2337 Failed to start program:  [55 / 1067]
What's different is I clicked on "Copy to clipboard" and the dialog/errors went away; and I was presented a start.exe dialog
Image[/img]

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Tue Sep 03, 2013 5:30 pm

Alright. This is the most likely error cause for error 128 that you're seeing.

http://support.microsoft.com/default.as ... -us;184802

Let's test one more adjustment to the driver.

http://www.sandboxie.com/SandboxieInsta ... W2K3-2.exe
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Tue Sep 03, 2013 5:51 pm

I'm not sure that's it -- because I can call those two api's w/o issue...
But, you probably know more than I regarding this...

Using the latest:

Code: Select all

SBIE2204 Cannot start sandboxed service RpcSs (128)
Start.exe remains running. The Sandboxie service is running/started.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Sep 04, 2013 3:49 am

I was hoping just adjusting some offsets according to NTOSKRNL would do it, but it
starting to look like it's more complicated than just that. I might have to find my old
Server 2003 system to fix this problem. I'll let you know next week how I do with this.
tzuk

jassing
Posts: 11
Joined: Tue Aug 27, 2013 11:29 am
Location: United States
Contact:

Post by jassing » Wed Sep 04, 2013 5:48 pm

thank you for looking into it

Locked

Who is online

Users browsing this forum: No registered users and 2 guests