[.03] Blank IE window with Direct Access to Cookies

Listing issues addressed in beta version 4.05
Locked
tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

[.03] Blank IE window with Direct Access to Cookies

Post by tes » Thu Jun 27, 2013 9:29 pm

- using ie10 desktop version
- win8
- 32 bit
- registered and activated 4.03.02 sandboxie
- no other software in use


www.qz.com --> fails to load

unsandboxed --> in ie10 loads fine



Thank you for developing and ongoing support of this software.
T

nanana1
Posts: 161
Joined: Thu Oct 20, 2011 1:57 pm

Post by nanana1 » Thu Jun 27, 2013 10:23 pm

using ie10 desktop version
win7
64-bit
registered and activated 4.02
no other software in use


www.qz.com --> loads properly

Image

unsandboxed --> ie10 also loads fine
nanana1, a paid lifetime license Sandboxie user

tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

Post by tes » Sat Jul 20, 2013 9:46 am

- ie10 desktop version
- 4.05.01 sandboxie (registered and activated)
- win 8 / 32-bit
- no other software

www.qz.com --> still does not load

but unsandboxed loads fine


Thank you,
T

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sun Jul 21, 2013 4:17 am

OK, I will check on Windows 8.
tzuk

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Jul 25, 2013 9:18 am

Tested on Windows 8, both 32-bit and 64-bit, www.qz.com seem to load correctly for me with IE 10 under Sandboxie.
tzuk

tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

Post by tes » Thu Jul 25, 2013 10:30 am

hmm....

Thank you for checking...

Any ideas what I can try next?

(only internet/security software is Microsoft Security Essentials AV)

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Fri Jul 26, 2013 3:22 am

Can you first tell me what do you mean the site doesn't come up? What happens in the browser?
tzuk

tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

Post by tes » Sat Jul 27, 2013 8:16 am

if a screen cap says a thousand words...

http://postimg.org/image/6mwgl1a2v/full/
http://s7.postimg.org/a6ieaucsr/New_Bitmap_Image.gif


and the spinning thing in the middle just spins...


.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sun Jul 28, 2013 3:25 am

I understand, thanks. Do you want to post a Resource Access Monitor log? Might not help but certainly can't hurt.

http://www.sandboxie.com/index.php?Reso ... essMonitor
tzuk

tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

Post by tes » Sun Jul 28, 2013 12:33 pm

Here it is....
________________________________________________


snipped. --tzuk

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sun Jul 28, 2013 4:27 pm

Two things seem interesting:

First, it looks like you have some settings enabled in
Sandbox Settings > Applications > Web Browser > Internet Explorer

Is this correct? What happens if you turn those settings off?

Second, you have some Office plugins in Internet Explorer, it seems.
Can you try to disable them to see if it makes a difference?

Thanks!
tzuk

tes
Posts: 14
Joined: Mon Dec 17, 2012 7:50 am

Post by tes » Mon Jul 29, 2013 12:05 am

Bingo!!

The setting

[+] Allow direct access to Internet Explorer Cookies

was turned on. When turned off, the web page loads properly. I had turned it on a while back when I first loaded Windows 8 to try to fix the cookie issue prior to your fix.

Thank you very much.

-using-
- ie10 desktop version
- 4.05.02 sandboxie (registered and activated)
- win 8 / 32-bit
- no other software

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Jul 31, 2013 7:12 am

According to my tests, it is necessary to add one more Direct File Access setting to solve this problem.

Sandbox Settings > Resource Access > File Access > Direct Access
Click Edit/Add and paste:
%LocalAppData%\Microsoft\Internet Explorer\DOMStore\*

This is only necessary if you already enabled the following setting:

Sandbox Settings > Applications > Web Browser > Internet Explorer > Allow direct access to Internet Explorer cookies

I am going to revise the "Allow direct access to Internet Explorer cookies" setting to include this change
so there is no need to add this manually.
tzuk

Guest10
Posts: 5127
Joined: Sun Apr 27, 2008 5:24 pm
Location: Ohio, USA

Post by Guest10 » Wed Jul 31, 2013 10:03 am

tzuk wrote:%LocalAppData%\Microsoft\Internet Explorer\DOMStore\*
Personally, I find it confusing to see references to %LocalAppData% and %Local AppData%.
Since %LocalAppData% works here, is it the same variable as %Local AppData% ?

%Local AppData% appears through-out templates.ini.
%LocalAppData% does not.
Paul
Win 10 Home 64-bit (w/admin rights) - Zone Alarm Pro Firewall, MalwareBytes Premium A/V, Firefox, Thunderbird
Sandboxie user since March 2007

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Jul 31, 2013 10:39 am

Good point. Sandboxie treats the two forms the same way, but Local AppData with a space is the canonical one
from the User Shell Folders registry key. I will use Local AppData with a space for this new setting.
tzuk

Locked

Who is online

Users browsing this forum: No registered users and 1 guest