hl2.exe window not showing when loading Team fortress 2 game

Listing issues addressed in beta version 4.03
Locked
stephanie
Posts: 3
Joined: Fri Dec 16, 2011 12:53 pm

hl2.exe window not showing when loading Team fortress 2 game

Post by stephanie » Fri Jun 21, 2013 7:15 pm

sandboxie: 4.02 64bit
os: windows 7, 64bit
third-party software: steam, team fortress 2
steam download: http://store.steampowered.com/about/

In older versions of sandboxie, I could start Team Fortress 2 in textmode and it would launch just fine and show the hl2.exe window, but something got broken in the later versions. Now when you launch it, hl2.exe shows in sandboxie but no window shows at all for it.

-Image of hl2.exe in textmode that I found.

http://i1.ytimg.com/vi/hBHdlvWyPoM/maxresdefault.jpg

-Also an error/bug shows up to. With a lot of the same lines, but I'll show just a few.


SBIE2205 Service not implemented: Font Path C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\resource\tf2build.ttf
SBIE2205 Service not implemented: Font Path C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\resource\tf2build.ttf
SBIE2205 Service not implemented: Font Path C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2\resource\halflife2.ttf
SBIE2205 Service not implemented: Font Path C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2\resource\halflife2.ttf

viktual

Post by viktual » Fri Jun 21, 2013 8:27 pm

Many people are having issues using this program with Team Fortress 2. I tried a number of things to fix it, but going back to 3.76 was the only thing that worked.

PiwPi
Posts: 84
Joined: Mon Jan 31, 2011 6:36 pm

Post by PiwPi » Sun Jun 23, 2013 12:13 pm

Had to revert back to 3.76 as well. That one worked and is working flawlessly with TeamFortress2.

After reading around in this forum I've found out that the font issue doesn't only affect TF2, but also Adobe software:
Problems with fonts.

And here is another thread about TF2:
Can't view or open any .ttf files in Beta 4. 1.13


Please fix the font issue and stop the hl2.exe process from running silently in the background.

Idle

Fixed 4.04

Post by Idle » Wed Jul 10, 2013 1:06 pm

Using version 4.04 it looks to be fixed. :D

Julian
Posts: 180
Joined: Sun Aug 09, 2009 3:23 pm

Post by Julian » Thu Jul 11, 2013 2:34 pm

I have other issues with 4.04 and Team Fortress 2 running in a sandbox:
1. The font of the main menu is wrong
2. Mouse is going crazy after joining a match

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Post by tzuk » Thu Jul 11, 2013 2:42 pm

There was a post about mouse going crazy and reportedly fixed by adding OpenWinClass=*.

http://www.sandboxie.com/phpbb/viewtopic.php?t=15709

Try this workaround please.
tzuk

Julian
Posts: 180
Joined: Sun Aug 09, 2009 3:23 pm

Post by Julian » Fri Jul 12, 2013 5:06 pm

Yes, that helps.
Just feels a little insecure. :)

Locked

Who is online

Users browsing this forum: No registered users and 1 guest