[.01] Paste not working in sandboxed browsers

Listing issues addressed in beta version 4.03
Guest101

Post by Guest101 » Tue Jun 25, 2013 8:37 am

I installed the program "PolarEdit" into a sandbox and everthing worked fine. But since Sandboxie version 4.02/4.03.01 a copy and paste action crashes the program!

Download link: http://fortisclub.com/download_zip/Pola ... _0.728.zip

After the sandbox installation start the program and select the option "New". Now click on a channel name and select "Copy" from the right click menu. Then select "Paste" from the right click menu.

Peter 123
Posts: 90
Joined: Sun Jun 23, 2013 10:48 am

Post by Peter 123 » Tue Jun 25, 2013 8:39 am

Tzuk, thank you for your quick release of a beta version!

"Simple" copy and paste in my case continues to work flawlessly. (Even with version 4.02 for me it was only a temporary issue).

But unfortunately my main problem still exists:
Peter 123 wrote: I use to insert text from Word documents directly into the pages of a Wiki (not Wikipedia) by copy and paste (within my browser [Firefox]). Since using Sandboxie 4.02 pasting itself continues to work, but some (important for me) formatting details (like tables, underlining of words, ...) are now lost when pasting into the Wiki page.
---> All formatting is lost with the beta version too.
Windows 7 Home Premium 32 bit, Microsoft Security Essentials, Windows Firewall, Firefox

Radler
Posts: 7
Joined: Thu Jun 20, 2013 3:18 pm

Post by Radler » Tue Jun 25, 2013 9:38 am

Just updated to Version 4.03.01. Copy & Paste now working in Sandboxed JDownloader.
Thanks a lot for the Fix and quick release of the Beta Version.

Kleary
Posts: 3
Joined: Tue Jun 25, 2013 9:50 am

Post by Kleary » Tue Jun 25, 2013 10:02 am

Still doesn't work for me. Tried copying some url's and pasting into a new tab and nothing. Was able to paste them into Notepad++ fine.
I decided to sign up and had to log in before posting a reply here. I copied my post first but couldn't paste in this forum.
So no change after upgrading to the beta.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Jun 26, 2013 7:59 am

I looked into the copy/paste issues again and I think I understand what I was doing wrong.
I hope that version 4.03.02 which I will release soon will be fix all the copy/paste issues for you.
tzuk

Peter 123
Posts: 90
Joined: Sun Jun 23, 2013 10:48 am

Post by Peter 123 » Wed Jun 26, 2013 9:56 am

These are good news. Thank you for the information, tzuk. :D
Windows 7 Home Premium 32 bit, Microsoft Security Essentials, Windows Firewall, Firefox

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Jun 27, 2013 3:20 am

Please check version 4.03.02.
tzuk

Peter 123
Posts: 90
Joined: Sun Jun 23, 2013 10:48 am

Post by Peter 123 » Thu Jun 27, 2013 5:30 am

Yes, now for me it works perfectly again: With version 4.03.02 the issue with pasting / losing the formatting is fixed! :D

Thanks a lot, tzuk, for your great work!
Windows 7 Home Premium 32 bit, Microsoft Security Essentials, Windows Firewall, Firefox

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Jun 27, 2013 6:43 am

Thank you for the quick confirmation! :)
tzuk

Guest101

Post by Guest101 » Thu Jun 27, 2013 7:55 am

Yes, copy & paste works fine now! The issue with the program "PolarEdit" is solved! Thank you very much!

Kleary
Posts: 3
Joined: Tue Jun 25, 2013 9:50 am

Post by Kleary » Thu Jun 27, 2013 11:59 am

Seems to be working fine now. Thanks a lot tzuk.
All my tests went without a problem.

Slavka
Posts: 11
Joined: Thu Apr 12, 2012 12:44 pm

[4.02 32-bit] Paste Problems Inside Sandboxed Folders

Post by Slavka » Sun Jun 30, 2013 11:24 am

Hi All,
It is not possible to paste (copied or cutted) files/folders from a sendboxed folder to another sandboxed folder (same sandbox).

- Paste command via right click menu, does not work and the OS plays a error beep.
- Paste command via CTRL + v, does not work and the OS play a error beep.

- The only way to operate the paste (copied or cutted files/folders) is via drag and drop (DX and SX mouse buttons, both works).

This problem is not present in v3.76.

Windows 7 Ultimate 32-bit (all service packs and updates applied)
Avira Antivirus Premium 2013

nanana1
Posts: 169
Joined: Thu Oct 20, 2011 1:57 pm

Post by nanana1 » Sun Jun 30, 2013 11:44 am

The copy and paste bug has been fixed by tzuk with the release of 4.03.02 beta.
Please try it here : http://www.sandboxie.com/phpbb/viewtopic.php?t=15836
nanana1, a paid lifetime license Sandboxie user

Slavka
Posts: 11
Joined: Thu Apr 12, 2012 12:44 pm

Post by Slavka » Sun Jun 30, 2013 1:50 pm

Thanks a lot. Copy and Paste is working again with v4.03.02.

Regards.

0strodamus
Posts: 24
Joined: Mon Jul 05, 2010 2:24 pm
Location: Death Star aka USA

Post by 0strodamus » Mon Jul 01, 2013 12:14 am

v4.03.02 is causing intermittent copy/paste issues for me. It is the first version 4 to do so, which is just plain weird. Running Windows 7 x64. If I copy 2 or 3 times, it will paste eventually. This is happening both between sandboxed Firefox and applications outside the sandbox, and between Firefox GUI elements contained within the sandbox.
Sandboxie | NOD32 | Jetico Personal Firewall | MBAM Pro | SuRun | Acrylic DNS
OS: Windows 7 x64

Locked

Who is online

Users browsing this forum: No registered users and 1 guest