[.06] [.05] [.03] Copy to clipboard does not work

Listing issues addressed in beta version 4.01
tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Mar 20, 2013 12:34 pm

I merged your other topic here shadek.

I will remove this warning message in the next beta build because copy/paste seems to work well regardless.
tzuk

Helper
Posts: 135
Joined: Thu Mar 01, 2012 11:28 am

Post by Helper » Wed Mar 20, 2013 1:02 pm

shadek wrote:Maybe my info can share some light on the problem:

http://www.sandboxie.com/phpbb/viewtopic.php?t=15021
Nope. That link is dead.
If it all works, use the "Hide" button the next time you get the message.

shadek
Posts: 24
Joined: Sun Mar 10, 2013 6:06 am

Post by shadek » Wed Mar 20, 2013 2:41 pm

tzuk wrote:I merged your other topic here shadek.

I will remove this warning message in the next beta build because copy/paste seems to work well regardless.
Thanks tzuk. Great job as always!

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Wed Apr 10, 2013 10:02 am

I've decided to not yet remove that warning message in version 4.01.05 because I ended up identifying a bug in that code.

Hopefully this means the warning will no longer appear frequently for you, but it is still there and can give some hint in case of future problems.

Please let me know if there is some improvemt with these copy/paste issues in version 4.01.05.
tzuk

hx1997
Posts: 12
Joined: Mon Sep 17, 2012 10:15 am

Post by hx1997 » Fri Apr 12, 2013 12:48 pm

Sorry to say the problem with copying/pasting remained in version 4.01.05. No error messages were displayed.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sun Apr 14, 2013 2:22 pm

Sorry about that. It seems like this is not entirely uncommon so I'll probably have to figure it out before an official release of version 4. Unfortunately at this point I don't really have any idea what could be causing this.
tzuk

Sampei Nihira

Post by Sampei Nihira » Sun Apr 14, 2013 11:39 pm

[05]

OS XP Home service pack 3
Bug copy/paste present

Other pc OS W.7 not present.

Linsanity

Post by Linsanity » Tue Apr 16, 2013 8:40 am

Hi tzuk, installed 4.01.05 just to test the copy/paste and having similar problem but with "Opera" browser only. Opera outside of Sandbox copy/paste works normally. Tested on fresh install of Windows 7 x64.

Sampei Nihira

Post by Sampei Nihira » Tue Apr 16, 2013 9:33 am

Me too use Opera [XP] bug present.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Tue Apr 16, 2013 4:33 pm

I think I made some progress with this bug, as I posted in this topic,

http://www.sandboxie.com/phpbb/viewtopic.php?t=15229

Hopefully this will fix the problems you're seeing with copy/paste.
tzuk

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Mon Apr 22, 2013 6:35 am

Please check version 4.01.06.
tzuk

hx1997
Posts: 12
Joined: Mon Sep 17, 2012 10:15 am

Post by hx1997 » Wed Apr 24, 2013 10:13 am

Hi tzuk,

Problem remained in version 4.01.06 but I see progress! Now I am able to copy anything from a sandboxed program (except for Opera) and paste it to an unsandboxed one.

However, there is still some problems when:
- copying anything from an unsandboxed program to a sandboxed one
- copying anything from a sandboxed program to another ("Paste" menu item is not grayed out but when you click paste nothing is pasted)
- copying anything from Opera browser (my default browser by the way) to any program (sandboxed or unsandboxed)

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Thu Apr 25, 2013 4:19 am

I can successfully copy text in Opera and paste outside the sandbox. I'm sorry but I don't have any idea what might be causing these problem in your computer.
tzuk

shadek
Posts: 24
Joined: Sun Mar 10, 2013 6:06 am

Post by shadek » Thu Apr 25, 2013 10:52 am

Copy-paste works fine for me now in this .06 release.

Win 8 x64

Locked

Who is online

Users browsing this forum: No registered users and 2 guests