SandBoxie Steam - Steam Runs Fine, Games Won't Launch.

If it's not about a problem in the program
Post Reply
ohayjosh
Posts: 1
Joined: Fri Nov 02, 2018 1:43 pm

SandBoxie Steam - Steam Runs Fine, Games Won't Launch.

Post by ohayjosh » Fri Nov 02, 2018 1:55 pm

I followed this tutorial for setting up Sandboxie -

"Open up your Program Files directory where your Steam installation is (eg, C:\Program Files (x86)\)
Create a new folder named Steamsand. Now go into your normal Steam folder (eg, C:\Program Files (x86)\Steam\)
Copy the folder "SteamApps" and file "Steam.exe" and Paste them into your SteamSand folder (eg, C:\Program Files (x86)\SteamSand\) Install and Run SandBoxie. When it's open, At the top click "Sandbox" and "Create New Sandbox." Name it whatever you want, then Click OK. Once you've clicked OK, You'll see the new sandbox appear in the list, Right click on it and click "Sandbox Settings"

In Settings, Click the + next to "Resource Access", Then the + next to "File Access", Now click "Full Access" Now click the "Add" button and Browse to the previously created "SteamSand" folder. Click on your "SteamSand" folder and Click OK. Click Apply and then OK There will be a popup stating you changes configuration blahblahblah, Just click OK.

Now go back to that "SteamSand" folder, Right click on "Steam.exe" and click "Run Sandboxed." You'll get a popup which will have you chose which Sandbox to run it with. Click on your "Steam" sandbox and click OK. (You may need to select the UAC check box as well)
Steam will now open and prompt you to Login. Login with whatever account you want (Most likely your 2nd account)

Steam will automatically download all the missing files we didn't copy.
Done"

I followed all the steps, and after creating a desktop shortcut from my steamsand folder and running steam.exe in sandboxed mode with UAC enabled on a 2nd account, everything runs fine, but when I attempt to launch a game, nothing happens. No errors or anything. The steam message "launching game" shows for a second or 2, and then nothing. Steam also updates every time I run sandboxed, when it should already be up to date. I've tried multiple games and nothing is working. Also, next to the games, it says "playable via steam play", but that doesn't show in my normal steam. Not sure if that is a problem. Am I missing a step here?

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: SandBoxie Steam - Steam Runs Fine, Games Won't Launch.

Post by Barb@Invincea » Mon Nov 05, 2018 9:50 am

Hello ohayjosh,

I am not sure which steps are you referring to. In order to run something Sandboxed, you may install it on your host, and then right-click on the application --> Run Sandboxed.
By allowing Sandboxie full access to your games, you are letting it make changes over them, as if they were not Sandboxed (also, these changes do not apply if the applications reside in the sandbox). Please find more information here:
https://www.sandboxie.com/ResourceAccessSettings#file

As for the Steam never-ending updates, we have threads about it with a workaround:
viewtopic.php?p=128091#p128091

If you want to post a problem report, please review these guidelines so that we can better assist you:
viewtopic.php?f=11&t=19746
Be sure to clarify what are you trying to do, exactly.

(Once you provide the required information, we can move this thread to the problem reports section).

Regards,
Barb.-

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest