Page 1 of 1

Hardlinks Workarounds

Posted: Thu Feb 22, 2018 5:46 am
by Hardlinks

I see there are only a few complaints about Hardlinks. And I'm assuming it is still not an easy fix as Curt@invincea had said about it in a post he made or that there may not be enough of a demand by users for it to be worked on, which is understandable.

I'm currently using a Mod Manger for games and it requires Hardlinks which fail to be created while everything is running inside of a sandbox. So my quick question is, Does anyone have any thoughts or workarounds for this issue? Any input would be appreciated!

Also if I seem to be misunderstanding something about the issue please let me know. :)


Re: Hardlinks Workarounds

Posted: Thu Feb 22, 2018 4:03 pm
by Barb@Invincea
Hello Hardlinks,

Here are some related posts:


What is the issue that you are experiencing, exactly? And what posts are you referring to?


Re: Hardlinks Workarounds

Posted: Fri Feb 23, 2018 1:05 am
by Hardlinks
Hardlinks do not seem to be supported by Sandboxie. The application I would like to use creates Hardlinks, and I'm trying to see if it is at all possible to allow them to be created in a Sandbox by an application or if anyone has any workarounds for the issue.

The post I was referring to in my original post by Curt@invincea:
Curt@invincea wrote:
Fri May 22, 2015 11:35 am
No, they never worked correctly. Hardlinks were going right out of the sandbox. And unfortunately, it is not a simple fix. We will consider this for a future release.

I am interested in knowing how many people are running into issues with hardlinks. This is the 1st report we've had.
Thanks :)

Re: Hardlinks Workarounds

Posted: Fri Feb 23, 2018 7:57 am
by RooJ
Is this nexus mod manager by any chance? I had the same issue when modding skyrim. Luckily I had an older version of nmm which worked perfectly sandboxed so I just used that.

Re: Hardlinks Workarounds

Posted: Fri Feb 23, 2018 8:42 am
by Hardlinks
Hey RooJ,

Yeah I have actually tried NMM, Vortex Alpha and Mod Organizer all with the same issue, unfortunately from what I read it seems Fallout4 and Skyrim-SE require the use of Hardlinks.

If you were working with the Skyrim-SE edition, you would not happen to know the version of NMM you were on do you?


Re: Hardlinks Workarounds

Posted: Fri Feb 23, 2018 1:17 pm
by RooJ
Ahh sorry, I have the original version of skyrim, not SE. The version I have which doesn't use hardlinks is 0.56.1. Also doesn't have the .net framework requirements that the later version has.

Good luck