Automatic cleanup not working

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
Unknown_User_386
Posts: 0
Joined: Wed Dec 31, 1969 7:00 pm

Automatic cleanup not working

Post by Unknown_User_386 » Sat Jul 29, 2006 10:40 am

Hi Tzuk,

I just did a clean XPPro SP2 Windows install. I have a previous version of Sandboxie (v2.45-registered) - however, I decided to try the latest release (v2.49).

I set the Automatic Sandbox Clean-Up option to: When Sandboxie Closes. The automatic feature will not run - however, I can still delete and recover files manually.

I uninstalled v2.49 and reinstalled v2.45. No change. This feature did work with my previous installation.

Other programs running:

ZoneAlarm Free v6.5.731 - latest. Note-this is a later version than I was using previously. Perhaps this could be the problem?

AVG Free v7.1.394

Spyware Blaster v3.5.1

There are no other memory-resident programs.

Other programs:

Registry Mechanic
A-Squared Free (not memory-resident)
Ad-Aware SE Personal

Please let me know if you have any ideas? Thanks.

I always feel safer surfing with Sandboxie.

Alan

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Sat Jul 29, 2006 5:50 pm

Has anything else changed? Do you have the same sandbox top level folder as before, for example?

Also, does automatic clean up work, when you set it to when-last-program-ends?
tzuk

Unknown_User_386
Posts: 0
Joined: Wed Dec 31, 1969 7:00 pm

Post by Unknown_User_386 » Sat Jul 29, 2006 9:35 pm

Hi Tzuk,

Sorry I got this message in the wrong forum - and thanks for answering anyway.

I changed the cleanup option to: When Last Program Ends - and the Automatic cleanup feature now works.

I did not understand what the Top Level Folder was about - so I never made any changes to it.

I hope it is okay to change the subject. I had the issue with the Qurb anti-spam program. There was one additional issue - outside of Sandboxie, Qurb automatically moves the emails which do not have matching addresses to the Qurb folder. Inside of Sandboxie, I get a pop-up asking me where to place the messages.

I can easily do this manually - however, if you do have any ideas as to what the problem might be, I would be thankful.

Thanks again for your help.
Alan

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Mon Jul 31, 2006 3:47 pm

Hi Alan, I tested the cleanup thing today. It does work, at least for me, but I noticed a "little known feature" :wink:

If Sandboxie is configured to "Auto Delete When Sandboxie Closes", and there are any recoverable files in the folders listed for Quick Recovery, then auto-clean will not occur.

For some reason -- I can't for the life of me remember what was I thinking -- recoverable items are not checked when "Auto Clean When Last Program Ends". In this mode, the sandbox is always deleted.

It would probably make more sense the other way around ... But changing this will have to wait for another day.

Anyway -- perhaps this was your problem. Try reverting to "Auto Delete When Sandboxie Closes" now that your Quick Recovery folders are empty, and see if that makes a difference for you.
outside of Sandboxie, Qurb automatically moves the emails which do not have matching addresses to the Qurb folder. Inside of Sandboxie, I get a pop-up asking me where to place the messages.
I'll have to look into this and see what's confusing Qurb.
tzuk

Unknown_User_386
Posts: 0
Joined: Wed Dec 31, 1969 7:00 pm

Post by Unknown_User_386 » Mon Jul 31, 2006 5:09 pm

Hi Tzuk,

I tried the "When Sandboxie Closes" option - and for me it still does NOT clean out the Sandbox. Since it does work with the "When Last Program Ends" option, I will just continue to use that.

Also - I should point out that with my previous XP setup, the "When Sandboxie Closes" option DID work correctly all the time - even if there were files to be recovered. In fact, if I remember correctly, the "When Last Program Ends" option would not clean the Sandbox - just the opposite of what is happening now.

That is why I tried to reinstall the older Sandboxie version to see if it would start working - but perhaps some components were still in the system from the new version and prevented it from working correctly.

Hope you can find out what is going on with these 2 options.

Question - I have File Sharing and several of the system services (services.msc) turned off/disabled. Does Sandboxie need any system settings to be on/enabled to work correctly?

Thanks for your quick reply.

Best regards,
Alan

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Mon Jul 31, 2006 5:27 pm

Question - I have File Sharing and several of the system services (services.msc) turned off/disabled. Does Sandboxie need any system settings to be on/enabled to work correctly?
No, it doesn't need any of those.

Sandboxie doesn't use any services that aren't already required by Windows itself.
tzuk

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests