Sandboxed Thunderbird Links don't open Chrome

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
phrab
Posts: 48
Joined: Sat Mar 14, 2009 3:02 pm

Sandboxed Thunderbird Links don't open Chrome

Post by phrab » Sat Feb 16, 2019 9:15 pm

I have Windows 10, 64-bit, & just updated Sandboxie to version 5.28 (64-bit). Before updating, I've always been able to click email links in Thunderbird (version 60.5.1, 32-bit) & it opens in my default browser, Google Chrome (version 72.0.3626.109 (Official Build) (64-bit)).

After updating Sandboxie, I now get the following message:
"This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings Page".

I don't understand what happened because both Thunderbird & Chrome open, by default, in a Sandbox & they are my default apps. I didn't make any changes in the Sandboxie configuration.

How can I correct this?
Thank you in advance,
Attachments
Thunderbird Link.png
Thunderbird Link.png (11.05 KiB) Viewed 410 times
Phil
Windows 10 Pro, Version 1803, Build 17134.523 (64-bit)
Sandboxie version 5.28 64-bit
Chrome Version 72.0.3626.109 (Official Build) (64-bit)
Running Windows Defender
Also, Windows XP Pro SP-3
Sandboxie Version 5.06 32-bit
Firefox version 52.9.0 32-bit

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Barb@Invincea » Tue Feb 19, 2019 10:41 am

Hello phrab,

What are the repro steps? Is your browser running while you click on the hyperlinks? Or can you please provide the steps so that I can test this?

Also, what are your Windows default browser and email set to? (Not Sandboxie's, but Windows 10 itself).

Regards,
Barb.-

Siskiyou Sam
Posts: 2
Joined: Tue Feb 19, 2019 11:28 am

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Siskiyou Sam » Tue Feb 19, 2019 11:57 am

Hello Barbara,

I'm having the exact same problem and error message as phrab in Thunderbird (65.0.1 32-bit), but my default browser is Firefox (65.0.1, 64-bit). As with phrab, problems with opening hyperlinks between emails and the default browser started after upgrading Sandboxie to version 5.28 (64-bit) a few days ago. On Windows 10, 64-bit, version 1803. Get the error message whether or not Firefox previously started. Everything works as expected if Thunderbird is not sandboxed, with either links opening browser to website or links appearing in opened browser.

Windows 10 default apps are set to Firefox and Thunderbird.

Thunderbird is set to start as a "forced program" in Sandboxie and to close when Firefox closes.

Any ideas appreciated.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Barb@Invincea » Tue Feb 19, 2019 1:11 pm

Hi Siskiyou Sam,

I am wondering if things are related to this DDE issue:
viewtopic.php?p=135533#p135533

If possible, please follow the guidelines and provide all the info I requested as well, so that I can test this:
viewtopic.php?f=11&t=19746
viewtopic.php?p=135839#p135839

As an additional question: does it work with other browsers instead?

Regards,
Barb.-

phrab
Posts: 48
Joined: Sat Mar 14, 2009 3:02 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by phrab » Tue Feb 19, 2019 1:12 pm

Thank you for your reply!
My default browser: Chrome Version 72.0.3626.109 (Official Build) (64-bit)
My default email program: Thunderbird 60.5.1 (32-bit)

This occurs whether Chrome is running or not, sandboxed or not.

The steps to reproduce:
1. Start Thunderbird, which runs inside Sandboxie
2. Open any email which has a link
3. Click on that link.

Note: if I disable forced programs & open Thunderbird outside of Sandboxie & repeat steps 2 & 3 above, the link opens in Chrome outside of Sandboxie. i.e. everything works normally if I don't use Sandboxie.

In the meantime, I've temporarily downgraded Sandboxie to 5.26, which doesn't have the problem. However, I would like to upgrade if a solution can be found.
Thank you again!
Phil
Windows 10 Pro, Version 1803, Build 17134.523 (64-bit)
Sandboxie version 5.28 64-bit
Chrome Version 72.0.3626.109 (Official Build) (64-bit)
Running Windows Defender
Also, Windows XP Pro SP-3
Sandboxie Version 5.06 32-bit
Firefox version 52.9.0 32-bit

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Barb@Invincea » Wed Feb 20, 2019 10:25 am

Hi all ,

I installed Thunderbird v60.5.1 32 bit, updated FF to 65.0.1 64 bit, and ensured Chrome was up-to-date (v72.0.3626.109 64 bit)
Used Sbie 5.28 on Win 10 x64 v1809

First test:
On Windows 10 default apps, set Thunderbird as my email app, and FF as my default browser
Launched Thunderbird in a new Sandbox with default settings
Clicked on a link from an email , which opened Firefox Sandboxed
I clicked on another link, which opened a new tab in Sandboxed Firefox.

Second test:
I retested the above listed steps with Chrome (so I set it up as my default browser in Windows, then re-tested), same results.

Third test:
Same as the above but both Firefox and Chrome were launched across different Sandboxes (including the one I was using for Thunderbird). Links were properly directed to the Sandboxed default browser.

If you are doing something different please let me know.
Also, please test other browsers as I suggested, as your issue may be DDE related. And, test a new Sandbox with default settings (if needed, remove the forced programs , just to test in a fresh environment).

Regards,
Barb.-

phrab
Posts: 48
Joined: Sat Mar 14, 2009 3:02 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by phrab » Wed Feb 20, 2019 1:49 pm

Thank you for testing, Barb. I tested Sandboxie with different browsers as the default (Internet Explorer, & Microsoft Edge). I get the same results that I did before...the links wouldn't open a browser.

Sandboxie had stopped Microsoft Office Click-to-Run service, so I started it & tried again. Same result. With Sandboxie 5.26, I was able to open links in a browser with or without Microsoft Office Click-to-Run service running. I also tried rebooting & that made no difference. I still get the message that I uploaded in my first post.

I haven't changed anything related to DDE, & my other programs seem to all work.

Under Forced Programs, I have iexplore.exe, chrome.exe, firefox.exe & under Forced Folders, I have C:\Program Files (x86)\Mozilla Thunderbird. This has always worked properly in versions before Sandboxie 5.28.

When you say "test a new Sandbox with default settings (if needed, remove the forced programs , just to test in a fresh environment)", do you mean just to go to Sandboxie/Show Window/Sandbox/Create New Sandbox, using default settings? If so, how can I get rid of the extra sandbox if it doesn't change things?

Thank you again for your time & expertise.

ADDITIONAL: I just created a new sandbox with default settings. I tried to have it open Thunderbird (Sandboxie Control/Temp Sandbox/Run Sandboxed/Run email reader), but Thunderbird wouldn't start & I got this message twice:
"SBIE2212 Email reader 'thunderbird.exe' is not configured to run sandboxed"

I then went to Sandbox Settings/Email reader & double clicked on Thunderbird. I could then open Thunderbird in that new sandbox, BUT still had the same message when I clicked a link an email.

I don't know what else to try.
Phil
Windows 10 Pro, Version 1803, Build 17134.523 (64-bit)
Sandboxie version 5.28 64-bit
Chrome Version 72.0.3626.109 (Official Build) (64-bit)
Running Windows Defender
Also, Windows XP Pro SP-3
Sandboxie Version 5.06 32-bit
Firefox version 52.9.0 32-bit

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Barb@Invincea » Thu Feb 21, 2019 10:07 am

Hi phrab,

I am not sure what does Click to Run service have to do with this scenario...Are you mentioning it for a specific reason? Or are you trying to open say, "word", via hyperlinks?
Sandboxie had stopped Microsoft Office Click-to-Run service --> I am not sure that's possible, what are you seeing, exactly? Without details, I cannot help you.

DDE is not something you will change, please do read the post I provided before to see more details.

Can you please try other browsers as I suggested?
Set a different default browser in Windows 10 (click on Start, type "default apps"), and re-test the behavior after deleting the contents of your Sandbox.

If the problems persist, please post your Sandboxie config file (keep the newly created sandbox for now, so that I can compare)
Configure--> Edit configuration
Copy-paste the contents to your response
Highlight what you just pasted and click on the "</>" button to format them in the forums.

Regards,
Barb.-

Liumang
Posts: 2
Joined: Thu Feb 21, 2019 10:02 am

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Liumang » Thu Feb 21, 2019 10:21 am

I also have the same problem, but in my case is not Chrome but firefox.
The version of Thunderbird is 60.5.1 (32bit), firefox 60.5.1 (64 bit), win10 build 17134.619 and sandboxie 5.28.
This problem only occur when I run the thunderbird in the sandboxie, in other words:

1.
Both firefox and thunderbird are running in the sandboxie → Clicked on a link from an email and get the following message:
"This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings Page".

2.
Running firefox in default and thunderbird in the sandboxie → Clicked on a link from an email and get the following message:
"This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings Page".

3.
Running thunderbird in default and firefox in the sandboxie → Clicked on a link from an email and it could worked.

4.
Both thunderbird and firefox in default → Clicked on a link from an email and of course it could worked.

Hope this information can help.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Barb@Invincea » Thu Feb 21, 2019 10:59 am

Hi Liumang ,

Thanks for the info. What do you mean by running on default ? (running outside Sbie..or? ).

Regards,
Barb.-

phrab
Posts: 48
Joined: Sat Mar 14, 2009 3:02 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by phrab » Thu Feb 21, 2019 5:24 pm

Hi Barb:
Sorry if I wasn't clear. I already tried using different browsers as the default & tried it with box my current default configuration with Sandboxie 5.28 & with a new sandbox, which you asked me to create. I called the new sandbox temporary. I have posted the configuration.ini as you requested.

With either sandbox in Sandboxie 5.28, I always got the same issue, no matter what the default browser was. I got the message that I mentioned in my initial post, no matter what browser was the default. Also, if I downgrade to 5.26, I don't have the issue.

I only mentioned the click-to-run in my last post because when I installed or reinstalled Sandboxie, the installer popped up a message saying that that processed must be closed before Sandboxie was installed.

Thank you again for your time & expertise! (In the meantime, I downgraded to SBie 5.26)

Here is the .ini file:

Code: Select all

[GlobalSettings]

Template=WindowsRasMan
Template=RoboForm
Template=AdobeAcrobatReader
Template=LastPass
Template=7zipShellEx
Template=Avira_Antivirus
Template=WindowsLive
Template=OfficeLicensing
Template=OfficeClickToRun
ActivationPrompt=n
ForceDisableSeconds=60

[DefaultBox]

ConfigLevel=7
AutoRecover=y
Template=Chrome_Cookies_DirectAccess
Template=Thunderbird
Template=Chrome_Phishing_DirectAccess
Template=WindowsDefender
Template=RoboForm
Template=Chrome_Preferences_DirectAccess
Template=Chrome_Bookmarks_DirectAccess
Template=IExplore_History_DirectAccess
Template=IExplore_Favorites_RecoverFolder
Template=IExplore_Favorites_DirectAccess
Template=IExplore_Force
Template=Chrome_History_DirectAccess
Template=Chrome_Force
Template=Firefox_Bookmarks_DirectAccess
Template=Firefox_Force
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Desktop%
BorderColor=#00FFFF
Enabled=y
CopyLimitKb=102410
BoxNameTitle=n
ForceFolder=C:\Program Files (x86)\Mozilla Thunderbird
NotifyInternetAccessDenied=y
NeverDelete=n
AutoDelete=y

[UserSettings_087401AE]

SbieCtrl_UserName=phil
SbieCtrl_NextUpdateCheck=1551291068
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_ShowWelcome=n
SbieCtrl_HideWindowNotify=n
SbieCtrl_WindowCoords=515,212,1238,633
SbieCtrl_ActiveView=40022
SbieCtrl_RecoverTarget=C:\Users\Phil\Desktop
SbieCtrl_SaveRecoverTargets=y
SbieCtrl_TerminateNotify=n
SbieCtrl_TerminateWarn=n
SbieCtrl_ExplorerNotify=n
SbieCtrl_ExplorerWarn=n
SbieCtrl_EditConfNotify=n
SbieCtrl_ReloadConfNotify=n
SbieCtrl_ProcSettingsNotify=n
SbieCtrl_SettingChangeNotify=n
SbieCtrl_ShortcutNotify=n
SbieCtrl_ShouldDeleteNotify=n
SbieCtrl_AutoApplySettings=n
SbieCtrl_HideMessage=1301,firefox.exe
SbieCtrl_HideMessage=1301,chrome.exe
SbieCtrl_BoxExpandedView=DefaultBox
SbieCtrl_EnableLogonStart=y
SbieCtrl_EnableAutoStart=y
SbieCtrl_AddDesktopIcon=n
SbieCtrl_AddQuickLaunchIcon=n
SbieCtrl_AddContextMenu=y
SbieCtrl_AddSendToMenu=y
SbieCtrl_ProcessViewColumnWidths=250,70,300

[UserSettings_1E560293]

SbieCtrl_UserName=phil_2003
SbieCtrl_ShowWelcome=n
SbieCtrl_NextUpdateCheck=1538191812
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_WindowCoords=200,150,1237,632
SbieCtrl_ActiveView=40021

[TemplateSettings]

Tmpl.RoboForm.phil=C:\Users\Phil\Documents\RoboForm Data\Default Profile
Tmpl.Chrome.phil=C:\Users\Phil\AppData\Local\Google\Chrome\User Data\Default

5.28 temporary.ini

[GlobalSettings]

Template=WindowsRasMan
Template=RoboForm
Template=AdobeAcrobatReader
Template=LastPass
Template=7zipShellEx
Template=Avira_Antivirus
Template=WindowsLive
Template=OfficeLicensing
Template=OfficeClickToRun
ActivationPrompt=n
ForceDisableSeconds=60

[DefaultBox]

ConfigLevel=7
AutoRecover=y
Template=Chrome_Cookies_DirectAccess
Template=Thunderbird
Template=Chrome_Phishing_DirectAccess
Template=WindowsDefender
Template=RoboForm
Template=Chrome_Preferences_DirectAccess
Template=Chrome_Bookmarks_DirectAccess
Template=IExplore_History_DirectAccess
Template=IExplore_Favorites_RecoverFolder
Template=IExplore_Favorites_DirectAccess
Template=IExplore_Force
Template=Chrome_History_DirectAccess
Template=Chrome_Force
Template=Firefox_Bookmarks_DirectAccess
Template=Firefox_Force
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Desktop%
BorderColor=#00FFFF
Enabled=y
CopyLimitKb=102410
BoxNameTitle=n
ForceFolder=C:\Program Files (x86)\Mozilla Thunderbird
NotifyInternetAccessDenied=y
NeverDelete=n
AutoDelete=y

[UserSettings_087401AE]

SbieCtrl_UserName=phil
SbieCtrl_NextUpdateCheck=1551291068
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_ShowWelcome=n
SbieCtrl_HideWindowNotify=n
SbieCtrl_WindowCoords=515,212,1238,633
SbieCtrl_ActiveView=40022
SbieCtrl_RecoverTarget=C:\Users\Phil\Desktop
SbieCtrl_SaveRecoverTargets=y
SbieCtrl_TerminateNotify=n
SbieCtrl_TerminateWarn=n
SbieCtrl_ExplorerNotify=n
SbieCtrl_ExplorerWarn=n
SbieCtrl_EditConfNotify=n
SbieCtrl_ReloadConfNotify=n
SbieCtrl_ProcSettingsNotify=n
SbieCtrl_SettingChangeNotify=n
SbieCtrl_ShortcutNotify=n
SbieCtrl_ShouldDeleteNotify=n
SbieCtrl_AutoApplySettings=n
SbieCtrl_HideMessage=1301,firefox.exe
SbieCtrl_HideMessage=1301,chrome.exe
SbieCtrl_EnableLogonStart=y
SbieCtrl_EnableAutoStart=y
SbieCtrl_AddDesktopIcon=n
SbieCtrl_AddQuickLaunchIcon=n
SbieCtrl_AddContextMenu=y
SbieCtrl_AddSendToMenu=y
SbieCtrl_ProcessViewColumnWidths=250,70,300
SbieCtrl_BoxExpandedView=DefaultBox,Temporary

[UserSettings_1E560293]

SbieCtrl_UserName=phil_2003
SbieCtrl_ShowWelcome=n
SbieCtrl_NextUpdateCheck=1538191812
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_WindowCoords=200,150,1237,632
SbieCtrl_ActiveView=40021

[TemplateSettings]

Tmpl.RoboForm.phil=C:\Users\Phil\Documents\RoboForm Data\Default Profile
Tmpl.Chrome.phil=C:\Users\Phil\AppData\Local\Google\Chrome\User Data\Default

[Temporary]

Enabled=y
ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=Thunderbird
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Chrome_Phishing_DirectAccess
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Favorites%
RecoverFolder=%Desktop%
BorderColor=#00FFFF,ttl
For comparison, if necessary, here is the .ini file from Sandboxie 5.26:

Code: Select all

[GlobalSettings]

Template=WindowsRasMan
Template=RoboForm
Template=AdobeAcrobatReader
Template=LastPass
Template=7zipShellEx
Template=Avira_Antivirus
Template=WindowsLive
Template=OfficeLicensing
Template=OfficeClickToRun
ActivationPrompt=n
ForceDisableSeconds=60

[DefaultBox]

ConfigLevel=7
AutoRecover=y
Template=Chrome_Cookies_DirectAccess
Template=Thunderbird
Template=Chrome_Phishing_DirectAccess
Template=WindowsDefender
Template=RoboForm
Template=Chrome_Preferences_DirectAccess
Template=Chrome_Bookmarks_DirectAccess
Template=IExplore_History_DirectAccess
Template=IExplore_Favorites_RecoverFolder
Template=IExplore_Favorites_DirectAccess
Template=IExplore_Force
Template=Chrome_History_DirectAccess
Template=Chrome_Force
Template=Firefox_Bookmarks_DirectAccess
Template=Firefox_Force
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Desktop%
BorderColor=#00FFFF
Enabled=y
CopyLimitKb=102410
BoxNameTitle=n
ForceFolder=C:\Program Files (x86)\Mozilla Thunderbird
NotifyInternetAccessDenied=y
NeverDelete=n
AutoDelete=y

[UserSettings_087401AE]

SbieCtrl_UserName=phil
SbieCtrl_NextUpdateCheck=1551291068
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_ShowWelcome=n
SbieCtrl_HideWindowNotify=n
SbieCtrl_WindowCoords=515,212,1238,633
SbieCtrl_ActiveView=40022
SbieCtrl_RecoverTarget=C:\Users\Phil\Desktop
SbieCtrl_SaveRecoverTargets=y
SbieCtrl_TerminateNotify=n
SbieCtrl_TerminateWarn=n
SbieCtrl_ExplorerNotify=n
SbieCtrl_ExplorerWarn=n
SbieCtrl_EditConfNotify=n
SbieCtrl_ReloadConfNotify=n
SbieCtrl_ProcSettingsNotify=n
SbieCtrl_SettingChangeNotify=n
SbieCtrl_ShortcutNotify=n
SbieCtrl_ShouldDeleteNotify=n
SbieCtrl_AutoApplySettings=n
SbieCtrl_HideMessage=1301,firefox.exe
SbieCtrl_HideMessage=1301,chrome.exe
SbieCtrl_EnableLogonStart=y
SbieCtrl_EnableAutoStart=y
SbieCtrl_AddDesktopIcon=n
SbieCtrl_AddQuickLaunchIcon=n
SbieCtrl_AddContextMenu=y
SbieCtrl_AddSendToMenu=y
SbieCtrl_ProcessViewColumnWidths=250,70,300
SbieCtrl_BoxExpandedView=DefaultBox,Temporary

[UserSettings_1E560293]

SbieCtrl_UserName=phil_2003
SbieCtrl_ShowWelcome=n
SbieCtrl_NextUpdateCheck=1538191812
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_WindowCoords=200,150,1237,632
SbieCtrl_ActiveView=40021

[TemplateSettings]

Tmpl.RoboForm.phil=C:\Users\Phil\Documents\RoboForm Data\Default Profile
Tmpl.Chrome.phil=C:\Users\Phil\AppData\Local\Google\Chrome\User Data\Default

[Temporary]

Enabled=y
ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=Thunderbird
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Chrome_Phishing_DirectAccess
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Favorites%
RecoverFolder=%Desktop%
BorderColor=#00FFFF,ttl
Phil
Windows 10 Pro, Version 1803, Build 17134.523 (64-bit)
Sandboxie version 5.28 64-bit
Chrome Version 72.0.3626.109 (Official Build) (64-bit)
Running Windows Defender
Also, Windows XP Pro SP-3
Sandboxie Version 5.06 32-bit
Firefox version 52.9.0 32-bit

Siskiyou Sam
Posts: 2
Joined: Tue Feb 19, 2019 11:28 am

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Siskiyou Sam » Thu Feb 21, 2019 6:06 pm

Hi Barb - As did phrab, I tried all of your suggestions with negative results. The one difference that I noticed between your testing and phrab & my settings was the version on Windows 10. Both he and I were on version 1803; you tested with version 1809.

Since I was having the same problem on my laptop, I forced a Windows update on it to version 1809. The problem with links between Thunderbird and Firefox disappeared immediately on restart. I just finished updating my main computer to version 1809, and again, the problem disappeared and everything is working as expected.

Whether the Windows update reset a pointer, registry value, etc., or whether a Sandboxie code modification to have it work with version 1809 broke version 1803 is outside my expertise. I don't know if you can call this a "fix", but it worked for me.

Siskiyou Sam

Liumang
Posts: 2
Joined: Thu Feb 21, 2019 10:02 am

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Liumang » Thu Feb 21, 2019 10:43 pm

Barb@Invincea wrote:
Thu Feb 21, 2019 10:59 am
Hi Liumang ,

Thanks for the info. What do you mean by running on default ? (running outside Sbie..or? ).

Regards,
Barb.-
YUP!
The tern "running on default " that I mention means the program run outside the sandboxie.

Lindharin
Posts: 3
Joined: Wed Oct 05, 2016 9:04 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by Lindharin » Mon Mar 04, 2019 4:19 pm

Hi,

Just an FYI that I was having the same basic problem. Our mail client is eM, and after the latest Sandboxie update, clicking links in email wouldn't open Firefox. There were no error messages or other indications of what was blocking it.

Per Siskiyou Sam's observation about Windows versions, I checked and we still were at version 1803 also. I just completed the upgrade to Windows 10 version 1809 and links in my email client are now working again.

Thanks, Sam, for catching that detail!

phrab
Posts: 48
Joined: Sat Mar 14, 2009 3:02 pm

Re: Sandboxed Thunderbird Links don't open Chrome

Post by phrab » Sun Mar 10, 2019 4:01 pm

FYI. I haven't updated to 1809 yet, but here's what happened with Windows 10, version 1803. I "fixed" the issue by going back to Sandboxie version 5.26. However, every once in awhile, I get the same message that I showed in the first post when I click a link in Thunderbird. If I either reboot or log out of Windows & then login again, the problem corrects itself.

So unless the individuals that updated to version 1809 have intermittent problems, the problem seems to be with something relating to an update to 1803. Since this is recent, maybe I can track it down.
Phil
Windows 10 Pro, Version 1803, Build 17134.523 (64-bit)
Sandboxie version 5.28 64-bit
Chrome Version 72.0.3626.109 (Official Build) (64-bit)
Running Windows Defender
Also, Windows XP Pro SP-3
Sandboxie Version 5.06 32-bit
Firefox version 52.9.0 32-bit

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 12 guests