SBIE2101 error for previously working program (starcraft 2)

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
criscocube
Posts: 3
Joined: Tue Jan 27, 2015 9:50 am

SBIE2101 error for previously working program (starcraft 2)

Post by criscocube » Mon Jan 14, 2019 12:35 pm

:!: The Windows version number? (i.e. Windows 7 32bit, 8.1 x64, etc)
Windows 10 x64

:!: Sandboxie version number (SBIE v5.23.3? 5.22?)
5.26 (64 bit - latest version)

:!: Does the issue occur in a new Sandbox with Default settings? (https://www.sandboxie.com/SandboxMenu#create)
yes, I also tried giving full and also direct access to the entire HDD and it still happens

:!: NAME & Version/build numbers of any applications involved? (Chrome v43, FF45 etc)
starcraft 2 (up-to-date), battle.net running also but doesnt crash

:!: Are you running antivirus/anti-malware software? (AVG, Live Essentials..etc)
no, only windows defender (tried disabling it, no change)

:!: What are the exact steps to reproduce the issue? (Launch app X, perform X actions, etc)
Running the program/game, after a random amount of time (anywhere from 30 seconds to 4 minutes) the game crashes and sandboxie reports this error: SBIE2101. It seems to speed up crashing when it loads into a game from the menus (maybe related to ram usage or a memory leak?... i have 32gb of ram and was able to run 10x instances at a time previously no issues...)

The program previously worked without issue, hadn't used it in sandboxie for a while, tried again and got this issue.
Finally, sometimes there is no SB error but a program error (only 1 happens, never both) which from the crash dump txt is listed as an: ACCESS_VIOLATION (0xC0000005)

Any thoughts of why this no longer works and how to get it working?

Thanks!

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2911
Joined: Mon Nov 07, 2016 3:10 pm

Re: SBIE2101 error for previously working program (starcraft 2)

Post by Barb@Invincea » Tue Jan 15, 2019 11:33 am

Hi criscocube,

Unfortunately, this is out of support's scope:
viewtopic.php?f=2&t=24980

Here are a few ideas for you:
1 - Test to see if the issue happens outside Sandboxie.
2 - Since you mentioned battlenet, please review these threads for additional information:
search.php?keywords=battle.net
search.php?keywords=battlenet
3 - Try using Resource Access monitor to see if you can determine what needs to be opened.
https://www.sandboxie.com/ResourceAccessMonitor
4 - I know you mentioned the issue started recently, but might as well review these:
search.php?keywords=starcraft
5 - Reach out to the game support section to see if they are blocking Sandboxie (many games do).
6 - This may fail right away, but you may want to try installing the game inside Sandboxie, and/or copying the host installation to the Sandbox. Sometimes that can help (keep in mind not all programs can be installed inside the sandbox - drivers and services will not install in Sandboxie).

As for thoughts as to why it has stopped working:
Game updates
Windows updates
Driver updates

Regards,
Barb.-

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 24 guests