Clickonce aplication don't work [CLOSED - DUPLICATE]

Please post your problem description here

Moderator: Barb@Invincea

Locked
nuno.barros
Posts: 3
Joined: Mon Oct 29, 2018 12:48 pm

Clickonce aplication don't work [CLOSED - DUPLICATE]

Post by nuno.barros » Mon Oct 29, 2018 1:01 pm

:!: The Windows version number? (i.e. Windows 7 32bit, 8.1 x64, etc)

Windows 10 Pro x64 10.0.17763 N/A Build 17763

:!: Sandboxie version number (SBIE v5.23.3? 5.22?)

SB ie 5.27.1 x64

:!: Does the issue occur in a new Sandbox with Default settings? (https://www.sandboxie.com/SandboxMenu#create)

Yes, even after new install.

:!: NAME & Version/build numbers of any applications involved? (Chrome v43, FF45 etc)

Proprietary application, but every public clickonce application tested has the same problem

:!: Are you running antivirus/anti-malware software? (AVG, Live Essentials..etc)

Only default Windows Defender on host system

:!: What are the exact steps to reproduce the issue? (Launch app X, perform X actions, etc)

Execute application, files are downloaded to the sandbox, but fails to copy the files to the correct location, previous version worked correctly.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Clickonce aplication don't work

Post by Barb@Invincea » Tue Oct 30, 2018 9:47 am

Hello nuno.barros ,

Can you please provide a download link to the public app, and repro steps needed to set it up (if any?).

What do you mean it doesn't copy to the right location? Where are the files downloading, and where are they supposed to go after recovering them? (or what are the exact steps that you are following? )

Also, please keep in mind that reinstalling Sandboxie does not delete the contents of your Sandbox, so you will still need to create a new Sandbox with default settings for testing purposes.

Regards,
Barb.-

nuno.barros
Posts: 3
Joined: Mon Oct 29, 2018 12:48 pm

Re: Clickonce aplication don't work

Post by nuno.barros » Tue Nov 06, 2018 10:25 am

Hello Barb,

You can try this app it has the same problem.

https://clickonceget.azurewebsites.net/ ... rtetEditor

Step to reproduce:
- Open Internet browser sanboxed.
- Open URL provided, and clickonce app starts downloading.
- Should open the app at the end, but can´t complete copy to the sandboxed user profile folders.

As for the sandboxie, i've tried to delete all folders, uninstalled, reinstalled and only use the defaults, nothing worked.

NOTE: Unsandboxed clickonce apps work as expected, and on the previous version of sandboxie also worked fine.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2981
Joined: Mon Nov 07, 2016 3:10 pm

Re: Clickonce aplication don't work

Post by Barb@Invincea » Tue Nov 06, 2018 10:56 am

Hi nuno.barros ,

I am not sure what is the issue that you are reporting. But if it is related to installing apps, we have a thread about that:
viewtopic.php?f=11&t=26160

If it is not related to installing apps inside the Sandbox, please provide more info.

Regards,
Barb.-

nuno.barros
Posts: 3
Joined: Mon Oct 29, 2018 12:48 pm

Re: Clickonce aplication don't work

Post by nuno.barros » Tue Nov 20, 2018 9:36 am

Hi Barb,

The problem is fixed in version BETA 5.27.2, please close the topic.
Tks.

Locked

Who is online

Users browsing this forum: Google [Bot] and 8 guests