Failed to communicate with Sandboxie Service: *GUIPROXY

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Wed Dec 06, 2017 2:37 pm

It is now one year later and I am still seeing these notices. My old post is viewtopic.php?f=11&t=23829. This time it's on a Windows 7 computer running Sandboxie 5.20 and Chrome Beta, all 64-bit. Recently though I'm seeing it about once every day or two, after the computer resumes from hibernation. It has a bad side effect which is that one or more of the Chrome windows will lose their theme so to speak, and the minimize maximize and close buttons will no longer work. Also the tabs become transparent. To fix this I can select the tabs and drag them to a new window which restores the proper look. It's pretty weird.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by Barb@Invincea » Wed Dec 06, 2017 4:17 pm

Hello cornflake,

Have a look at this thread regarding Chrome dev edition:
viewtopic.php?p=130933#p130933

Did you try hiding the message as recommended before?
Is there any security software installed?
What is the full message that you receive?
Are there any extensions installed?
What version of Chrome are you using?

Regards,
Barb.-

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Fri Dec 08, 2017 3:05 pm

The actual error message this time is:

Code: Select all

SBIE2203 Failed to communicate with Sandboxie Service:  *GUIPROXY_00000001 - chrome.exe [00000102]
SBIE2203 Failed to communicate with Sandboxie Service:  *GUIPROXY_00000001 - chrome.exe [00000102]
I'm not hiding it because I want to know when it happens. Also it has a bad effect as I described where it messes up the windows theme on the chrome windows.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by Barb@Invincea » Fri Dec 08, 2017 4:54 pm

Hello cornflake,

I cannot reproduce the GUIPROXY issue using the latest Sandboxie beta.
Did you try the steps I provided?
Does the issue follow you to a new Sandbox with default settings?

Regarding hibernation, I tried testing it on a VM but the whole thing (UI) crashes when I try to resume windows (even without Chrome). I'll try on the host (diff OS) to see if I can replicate.
Does Chrome work fine if you open it outside Sandboxie, then put your computer to hibernate and wake it up after a few minutes?
What's your AV software?
Are there any Chrome extensions added to the mix? I am assuming you are using the latest Dev Edition.

Regards,
Barb.-

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Fri Dec 08, 2017 5:22 pm

Thank you for trying. I am using a Chrome Beta 63.0.3239.52. I am going to update to the latest Chrome release build and I will also update Sandboxie to 5.23.1, and I will let you know in a few days or less whether or not I still have the same problem.

As far as the steps provided if you're asking if I added --no-sandbox to Chrome, no I did not. I do not have any AV software except Windows Defender on this computer, and no extensions. Yes Chrome appears to work fine without Sandboxie and does not have the problem.

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Fri Dec 22, 2017 10:08 pm

I have been using Sandboxie 5.23.1 and the latest Chrome 63.0.3239.108 for about a week. Only one resume from the last week have I noticed a GUIPROXY message. There has not been any window theme corruption. If I have any more window theme issues I'll post again.

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Thu Jan 25, 2018 2:07 pm

For the last few days I've received the gui proxy messages every time I resume the computer and it's resulted in some window theme corruption (minimize/maximize/restore don't work). Windows 7, Sandboxie 5.23.3 x64, Chrome 63.0.3239.132 x64

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by Barb@Invincea » Thu Jan 25, 2018 5:20 pm

Hello cornflake ,

I'll re-test this tomorrow and let you know the outcome.
Can you please provide your sandboxie configuration file , so that I can re-create the scenario?
Configure--> Edit Configuration
Cop/Paste contents here
Highlight contents and hit the "</>" button to format them.

Regards,
Barb.-

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Thu Jan 25, 2018 6:46 pm

My entire Sandboxie.ini is huge and contains confidential information. I can give you the GlobalSettings and Chrome sandbox sections. It is the same in Windows 8.1 as well.

Code: Select all

[GlobalSettings]

TemplateReject=WindowsRasMan
TemplateReject=nVidia_Stereoscopic3D
TemplateReject=WindowsLive
TemplateReject=OfficeLicensing
ActivationPrompt=n
Template=SystemAudioStream
Template=BitVise
Template=7zipShellEx
Template=AdobeAcrobatReader
Template=nVidia_nView
ClosedFilePath=\Device\QWAVEdrv

[Chrome]

Enabled=y
ConfigLevel=7
AutoRecover=y
NeverDelete=y
Template=Chrome_Force
Template=BlockPorts
Template=LingerPrograms
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Favorites%
RecoverFolder=%Desktop%
BorderColor=#00FFFF,off
BoxNameTitle=n
ProcessGroup=<ChromePrograms>,chrome.exe
ForceProcess=<ChromePrograms>
DropAdminRights=y

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by Barb@Invincea » Fri Jan 26, 2018 10:43 am

Hello cornflake,

I cannot repro these behaviors.

I know you have been reporting this for a while, viewtopic.php?p=125328#p125328 and the suggestion to hide the message might be the best way to go, if no functionality is affected. If you can also think about what are the common things between your 2 OS (installed AV, graphics drivers, settings....) that may help finding out a possible trigger.

As for the other issue, have you tried updating your video drivers (and/or reverting to a prior driver) to see if that helps?
Does it work fine outside Sandboxie?
Try removing the nvidia templates and see if that makes a difference.
Try a new Sandbox with default settings as well.

If you can reproduce the issue, please run Resource Access Monitor so that we can review it: (not sure we'll be able to find much, but worth a shot)
https://www.sandboxie.com/ResourceAccessMonitor

Regards,
Barb.-

cornflake
Posts: 246
Joined: Fri May 13, 2011 5:44 pm

Re: Failed to communicate with Sandboxie Service: *GUIPROXY

Post by cornflake » Fri Jan 26, 2018 4:32 pm

Thanks for your help. I think since I am the only one with this problem recurring it is probably something on my computers but I don't know what. I can't think of any more information that can be used to reproduce except that on both I usually have many tabs open. The two computers are very different. One is a Windows 7 HP desktop and the other is a Windows 8.1 Dell laptop. Both have Intel graphics and Intel CPU chips. Everything works fine outside of Sandboxie as far as I can see. Normally I run Chrome in Sandboxie though.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 10 guests