SBIE1406 and SBIE 1412 after Windows 10 Creators Update [SOLVED]

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
FrankieW
Posts: 16
Joined: Wed Jun 14, 2017 7:51 pm

SBIE1406 and SBIE 1412 after Windows 10 Creators Update [SOLVED]

Post by FrankieW » Tue Sep 05, 2017 7:02 pm

Hello,

I recently received the Windows 10 version 1703 the creator's update, and ever since every time I use Sandboxie I get the following errors:

SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [DefaultBox] %temp%

and the error repeats for all my sandboxes i.e. I'll get the same error pop up for all sandboxes at once. If sandboxie is running (icon in tray) then the error pops up sometimes even when I'm not actually using sandboxie for anything.

Other than the pop up error, I can use sandboxie as normal, it works fine. I'm using sandboxie 5.20.

Any ideas? Thanks

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by Syrinx » Tue Sep 05, 2017 7:44 pm

I can't reproduce it on a clean install of Windows 10 CU with Sandboxie 5.20. As a workaround I'd try going into your boxes and removing whatever rule exists there that includes %temp% or set it up with the actual path if you're the only user.

The odd part is that it isn't actually having the problem with %temp% itself but it can't resolve the %USERPROFILE% part so it'll likely effect all other similar variables or anything else that uses it.

Another option might be to try setting up a new user account and see if it happens with that as well.

If you're comfortable with regedit you could also navigate to HKEY_CURRENT_USER\Volatile Environment and see what path is set for USERPROFILE and if it's accurate. It should be C:\Users\*YOURUSERNAME* by default
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

FrankieW
Posts: 16
Joined: Wed Jun 14, 2017 7:51 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by FrankieW » Thu Sep 07, 2017 1:09 am

Hello,

unfortunately I think to reproduce it you'd have to install the same update on the same system, hence why I'm having the issue...

going into the boxes and removing rules involving %temp% - - - what rules are those, where are they, I'm not aware of any

set it up with the actual path if I'm the only user - - - set what up, how do I do that, what path is it normally, yes I am the only user

I'm not setting up a new user account over a sandboxie error, that's a bit long, besides I'm not concerned whether or not it happens in another account I simply want to fix it in this account

I checked regedit and the USERPROFILE path is accurate

Only similar thing I could find was viewtopic.php?f=11&t=23136, I tried reinstalling sandboxie too but no joy, I don't see anything about %temp% in sandboxie.ini, and HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
TEMP is already %SystemRoot%\TEMP, so nothing to alter there.

Perhaps the advice in that link could be tweaked to apply to my situation, any ideas welcome

FrankieW
Posts: 16
Joined: Wed Jun 14, 2017 7:51 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by FrankieW » Sun Sep 10, 2017 3:55 pm

Hello again,

could someone please tell me the steps to take to solve this error? The exact popup looks like this:

SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [custombox1] %temp%
SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [DefaultBox] %temp%
SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [custombox2] %temp%
SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [custombox1] %temp%
SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [DefaultBox] %temp%
SBIE1406 Missing or invalid expansion for USERPROFILE: [C0000034]
SBIE1412 In text: [custombox2] %temp%

As far as I can see in regedit the user account (user/appdata/local/temp) and system account environment variables (systemroot/temp) for the temp folder are Windows defaults. There is nothing sandboxie-related in the %temp% folder. Exploring the contents of the actual sandbox (c: - sandbox - (my userprofile) - Defaultbox - user - current - AppData - local - Temp), the temp folder is empty there too. Should there be something in there? Is Sandboxie unable to write in there or something?

I read these links too:

https://www.sandboxie.com/SBIE1406
https://www.sandboxie.com/SBIE1412
https://www.sandboxie.com/ExpandableVariables

but I still can't apply it to my situation. So Sandboxie cannot determine the location of the user account root folder while processing the %temp% configuration file? So what change do I need to make? I don't see anything about USERPROFILE or %temp% in Sandboxie.ini or in any of my sandbox contents or settings.

Note this error sometimes pops up even when I'm not using sandboxie, so long as sandboxie control is running in the task bar, is that significant?

I understand there is another temp folder at C:\Windows\Temp. There is no link to that when exploring the contents of a sandbox, the only thing in the windows folder in the sandbox contents is System32, so I suppose the windows temp folder isn't used when running Chrome. Is Is this relevant?

Someone please help, thanks

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by Syrinx » Mon Sep 11, 2017 5:38 pm

Short of being able to reproduce this I think the best test would actually be to see if this persists for a new user. It's possible something got corrupted during the upgrade process but if a new use profile doesn't show the same results then we'd know for sure it isn't SBIE specific.

As for not seeing any %temp% rules - Would you copy and paste the contents of your C:\Windows\Sandboxie.ini here (or in a PM) for us (me), please? It could easily involve a template rule you have enabled or some other thing that isn't quite so obvious but still related.
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

FrankieW
Posts: 16
Joined: Wed Jun 14, 2017 7:51 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by FrankieW » Thu Sep 14, 2017 3:52 pm

Hi, sorry for the late reply I've been busy. I can't be the only one in the world having this issue, there must be a simple path redirect somewhere or something to solve it I just don't know enough to do so. Here are the contents of my Sandboxie.ini file, hope it helps.

Code: Select all

[GlobalSettings]

Template=WindowsRasMan
Template=Avira_Antivirus
Template=WindowsLive
Template=OfficeLicensing
EditPassword=09070E090602040C0403030D060B0305050A0D0D
EditAdminOnly=y
ForceDisableAdminOnly=n
ForgetPassword=y

[UserSettings_0BCE01F9]

SbieCtrl_UserName=tinchala
SbieCtrl_NextUpdateCheck=1506001565
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_ShowWelcome=n
SbieCtrl_WindowCoords=350,173,876,412
SbieCtrl_ActiveView=40021
SbieCtrl_AutoApplySettings=n
SbieCtrl_EnableLogonStart=y
SbieCtrl_EnableAutoStart=y
SbieCtrl_AddDesktopIcon=y
SbieCtrl_AddQuickLaunchIcon=y
SbieCtrl_AddContextMenu=y
SbieCtrl_AddSendToMenu=y
SbieCtrl_ProcessViewColumnWidths=250,70,300
SbieCtrl_BoxExpandedView=custombox1,custombox2,DefaultBox

[custombox1]

ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=Chrome_Bookmarks_DirectAccess
Template=AutoRecoverIgnore
Template=Firefox_Phishing_DirectAccess
Template=Chrome_Phishing_DirectAccess
Template=LingerPrograms
Template=BlockPorts
Template=WindowsFontCache
Template=qWave
RecoverFolder=%Desktop%
RecoverFolder=%Favorites%
RecoverFolder=%Personal%
RecoverFolder=%{374DE390-123F-4575-9144-39C4935E567B}%
BorderColor=#00FFFF,ttl
Enabled=y
AutoDelete=y
NeverDelete=n
NotifyInternetAccessDenied=y
ProcessGroup=<StartRunAccess>,chrome.exe
ProcessGroup=<InternetAccess>,chrome.exe
NotifyStartRunAccessDenied=y
LeaderProcess=chrome.exe
ClosedFilePath=!<InternetAccess>,InternetAccessDevices
ClosedIpcPath=!<StartRunAccess>,*
DropAdminRights=y

[DefaultBox]

ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=AutoRecoverIgnore
Template=Firefox_Phishing_DirectAccess
Template=Chrome_Phishing_DirectAccess
Template=LingerPrograms
Template=BlockPorts
Template=WindowsFontCache
Template=qWave
RecoverFolder=%Desktop%
RecoverFolder=%Favorites%
RecoverFolder=%Personal%
RecoverFolder=%{374DE390-123F-4575-9144-39C4935E567B}%
BorderColor=#00FFFF,ttl
Enabled=y
AutoDelete=y
NeverDelete=n
NotifyInternetAccessDenied=y
ProcessGroup=<InternetAccess>,chrome.exe,firefox.exe
ProcessGroup=<StartRunAccess>,chrome.exe,firefox.exe
NotifyStartRunAccessDenied=y
LeaderProcess=firefox.exe
LeaderProcess=chrome.exe
DropAdminRights=y
ClosedIpcPath=!<StartRunAccess>,*
ClosedFilePath=!<InternetAccess>,InternetAccessDevices

[custombox2]

ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Chrome_Phishing_DirectAccess
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE390-123F-4575-9144-39C4935E567B}%
RecoverFolder=%Personal%
RecoverFolder=%Favorites%
RecoverFolder=%Desktop%
BorderColor=#00FFFF,ttl
Enabled=y
AutoDelete=y
NeverDelete=n
NotifyInternetAccessDenied=y
ProcessGroup=<InternetAccess>,chrome.exe,firefox.exe
ProcessGroup=<StartRunAccess>,chrome.exe,firefox.exe
NotifyStartRunAccessDenied=y
ClosedIpcPath=!<StartRunAccess>,*
ClosedFilePath=!<InternetAccess>,InternetAccessDevices
LeaderProcess=firefox.exe
LeaderProcess=chrome.exe
DropAdminRights=y

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by Syrinx » Thu Sep 14, 2017 4:26 pm

hrm, yeah, offhand I don't see anything that might even cause Sandboxie to try and expand %temp% though there are plenty of other variables in there they don't seem to be involved in the error as reported. Sorry, as of now trying a new user account with the same sandboxie.ini may be the only to tell. Anyone else, ideas?
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2668
Joined: Mon Nov 07, 2016 3:10 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by Barb@Invincea » Thu Sep 14, 2017 4:29 pm

Hello FrankieW,

Please have a look at these: (Be sure to highlight the SBIE message and select "Hide" instead of "Close").
viewtopic.php?f=5&t=21139&p=109405&hili ... LE#p109405
(This was the recommendation he referred to :
viewtopic.php?f=5&t=21139&p=109405&hili ... LE#p109279 )

If the above listed doesn't work and your variables are fine and everything else seems to be working as expected, try a different location for the container and see if you receive the same error.
Sandboxie Control ---> Sandbox ---> Set Container Folder
Choose a drive, if you click on it, it will switch it to the default location (if you have a specific location set, you may want to copy it somewhere before doing this).
Create a new Sandbox and try launching an application from it.

Regards,
Barb.-

FrankieW
Posts: 16
Joined: Wed Jun 14, 2017 7:51 pm

Re: SBIE1406 and SBIE 1412 after Windows 10 Creators Update

Post by FrankieW » Sat Sep 16, 2017 3:56 pm

Hi, those suggestions solved the problem. I waited a while to be sure and its definitely solved. Thanks

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 16 guests