AVG - Web Browsers - Could not hook CoGetObject - [SOLVED]

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
cafe_cyber
Posts: 2
Joined: Sun Sep 03, 2017 8:33 am

AVG - Web Browsers - Could not hook CoGetObject - [SOLVED]

Post by cafe_cyber » Sun Sep 03, 2017 9:21 am

Hi, hope someone can help me with this issue as I am desperate after trying to fix it for hours. :(

PROBLEM
All my programs work fine in Sandboxie except (suddenly) Internet Explorer and Chrome. When starting sandboxed browsers, I receive the following error messages:
- for Internet Explorer:
SBIE2303 Could not hook CoGetObject (1)

- for Google Chrome:
SBIE2303 Could not hook CoGetObject (1)
SBIE2303 Could not hook CoGetObject (1)
SBIE2203 Failed to communicate with Sandboxie Service: *GUIPROXY_00000001 - chrome.exe [FF000002]

CONFIG
  • Windows 7 64 bit
  • Sandboxie Version 5.20 (64 bit) registered and licence activated until 2018
  • Internet Explorer 11 without ad-blocker
  • Google Chrome Version 60.0.3112.113 (Official Build) (64-bit) without ad-blocker
  • AVG AntiVirus Free 17.6.30.29
  • Windows Firewall
  • CryptoPrevent = disabled

TRIALS AND ERRORS
None of the following tricks worked:
  • uninstalling and reinstalling Sandboxie
  • uninstalling and reinstalling Sandboxie in a different folder
  • deleting the content of the sandbox
  • creating a new sandbox
  • adding Sandboxie to the Windows firewall exception list
  • adding the Sandboxie Program Files folder to the AVG Resident Shield exceptions

MY ANALYSIS
Sandboxie was working fine before, and still works fine for all non-browsing programs (File Explorer, Audacity, VLC, etc.). Both IE and Chrome work fine when not sandboxed. So my Sandboxie install is OK, I guess. However something is blocking all sandboxed browsers from opening correctly. Is there a Sandboxie log that would show what is happening when I try to start IE or Chrome?

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 620
Joined: Fri Nov 13, 2015 4:11 pm

Re: Web browsers (only) not working

Post by Syrinx » Tue Sep 05, 2017 12:41 pm

For AVG, tested on 17.6.3029 along with chrome.
You can add this in the boxes you are having problems with alongside the new version of AVG to prevent the crash.

Code: Select all

ClosedFilePath=*avg*snxhk*.dll
or via the GUI Sandbox Settings > Resource Access > File Access > Blocked Access > Add >

Code: Select all

*avg*snxhk*.dll
Goo.gl/p8qFCf

Jimmy888
Posts: 2
Joined: Sat Sep 02, 2017 10:33 am

Re: Web browsers (only) not working

Post by Jimmy888 » Tue Sep 05, 2017 1:43 pm

Worked great.
Thanks

KevinRt66
Posts: 2
Joined: Thu Sep 07, 2017 7:38 pm

Re: Web browsers (only) not working

Post by KevinRt66 » Thu Sep 07, 2017 7:53 pm

I just started having this problems today though it's worked fine every day in the past :(

It's very vague & unclear what's meant by "add this in the boxes" :(

When I goto AVG settings, exceptions I added "ClosedFilePath=*avg*snxhk*.dll" there & it didn't work :(

via the GUI Sandbox Settings > Resource Access > File Access > Blocked Access > Add >

I can't add "*avg*snxhk*.dll" it's asking me to select a directory/path

Any help with the needed details is appreaciate. Thx!

cafe_cyber
Posts: 2
Joined: Sun Sep 03, 2017 8:33 am

Re: Web browsers (only) not working

Post by cafe_cyber » Fri Sep 08, 2017 4:25 am

It worked! Thanks Syrinx :D

KevinRt66
Posts: 2
Joined: Thu Sep 07, 2017 7:38 pm

Re: Web browsers (only) not working

Post by KevinRt66 » Fri Sep 08, 2017 11:08 am

I'm having this problem too
"Could not hook CoGetObject (1)"
"Sandboxed program has crashed: firefox.exe"

Windows 7 64bit
Sandboxie 5.20
FF 55.0.3
AVG 17.6 (latest)

I tried
"add this in the boxes you are having problems with alongside the new version of AVG to prevent the crash.
ClosedFilePath=*avg*snxhk*.dll

though that's very vague & unclear where we put it. Can you clarify incase I did it wrong?

I tried
" via the GUI Sandbox Settings > Resource Access > File Access > Blocked Access > Add >
*avg*snxhk*.dll

though it won't let me enter that & wants me to select folder/path. I entered 3 that have AVG DLL's in them & it didn't help :(

Will there be a fix in the next release so others don't have this problem & incase we can't get it resolved & I have to wait?

henryg
Posts: 531
Joined: Wed Nov 22, 2006 9:38 am

Re: Web browsers (only) not working

Post by henryg » Fri Sep 08, 2017 12:45 pm

Try Edit/Add rather than Add?

Personally, I put "ClosedFilePath=*avg*snxhk*.dll" in the config manually under Global Settings (Configure/Edit Configuration) but it depends what you want.

Good luck.
Henry

utmuk
Posts: 3
Joined: Wed Jul 31, 2013 11:36 am

Re: AVG - Web Browsers - Could not hook CoGetObject - [SOLVED]

Post by utmuk » Mon Sep 18, 2017 9:53 am

Reinstall helped me. I don't have AVG.

PS. I also restored the same Sandboxie.ini from old installation. So I doubt this has to do with settings.

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests