sandboxes not always deleting contents with Firefox 55?

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
rm22
Posts: 76
Joined: Sun Nov 02, 2014 2:31 am

sandboxes not always deleting contents with Firefox 55?

Post by rm22 » Sun Sep 03, 2017 2:06 am

I'm running Sbie 5.20 on Win 10 (1511)

For a few weeks now I have been having issues with sandboxes running Firefox 55.x not deleting contents after program termination - I have the sandboxes configured to auto-delete contents. I"d guess it's happening about 40% of the time - often enough that I've created an Explorer shortcut to the sandbox folder so I can shred them easily with Eraser. I am suspicious that it has to do with "pingsender.exe" - I've also noticed a few times this executable has failed to terminate as well & then a reboot is required to clear the sandbox contents.

Anyone else having this issue & been able to isolate the problem?

Thanks

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: sandboxes not always deleting contents with Firefox 55?

Post by Syrinx » Sun Sep 03, 2017 12:49 pm

I don't usually mess with the beta/nightly builds but a quick google search says pingsender is used for sending telemetry back. I'd try adding firefox.exe as a leader program and pingsender.exe as a lingering program so hopefully that when firefox terminates SBIE will kill pingsender and the box will close/delete as seems to be your desire.
Sandbox Settings > Program Stop > Lingering Programs/Leader Programs

If there is anything left running in the box Sandboxie will not try to preform the close actions. If the box closes but Sandboxie can't delete it (usually due to file access issues with another program outside the box) then it should pop up an error informing you, are you getting those?
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

rm22
Posts: 76
Joined: Sun Nov 02, 2014 2:31 am

Re: sandboxes not always deleting contents with Firefox 55?

Post by rm22 » Sun Sep 03, 2017 4:37 pm

firefox 55.x is general release.

I have execution & internet access restricted in my firefox sandbox so Pingsender was blocked for awhile when it was introduced - I actually allowed pingsender to run to see if that would fix the issue. So I'll try putting firefox in as a leader program, but I wouldn't think that would help in this case - we'll see...

I have noticed a few times programs are not terminating, but I don't think i'm getting a popup unless i manually try to terminate the lingering programs and they are unable to terminate

bo.elam
Sandboxie Guru
Sandboxie Guru
Posts: 2859
Joined: Wed Apr 22, 2009 9:17 pm

Re: sandboxes not always deleting contents with Firefox 55?

Post by bo.elam » Sun Sep 03, 2017 8:35 pm

rm22, You should try adding firefox.exe as Leader program as suggested by Syrinx. It should work.

Bo

rm22
Posts: 76
Joined: Sun Nov 02, 2014 2:31 am

Re: sandboxes not always deleting contents with Firefox 55?

Post by rm22 » Mon Sep 04, 2017 12:36 am

I've added it so we'll see... I didn't try it before since I still had the same issue with pingsender completely blocked and therefore I assumed it wouldn't help - I've only noticed it lingering a few times - I believe the sandbox had all programs terminated and was still not deleting contents some of the time. I can't be sure though - I haven't tested thoroughly

Thanks for the feedback guys - I'll report back in a few days

rm22
Posts: 76
Joined: Sun Nov 02, 2014 2:31 am

Re: sandboxes not always deleting contents with Firefox 55?

Post by rm22 » Wed Sep 06, 2017 7:01 pm

OK - here are some test results...

With "Pingsender.exe" blocked - the sandbox contents are NOT deleted, but there are NO lingering programs - this happens 100% of the time & there is a popup of "pingsender is canceled..." if the popup box is selected in settings - but there is no mention of the contents not being deleted. The contents can be deleted manually from Sbie Control or Explorer

with "Pingsender.exe" allowed - the sandbox contents are usually deleted, but are sometimes not & there is a popup of "can't delete because used by another program...", but they are not being used by another program and I can delete them manually from Explorer.

Having firefox.exe added as a "leader" program eliminates a few of the cases where contents were not deleting because pingsender.exe was not shutting down.

So pingsender.exe definitely seems to be causing problems for Sbie

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: sandboxes not always deleting contents with Firefox 55?

Post by Syrinx » Wed Sep 06, 2017 7:20 pm

Would you try adding *pingsender.exe under ClosedFilePath and see if that changes anything instead of relying on StartRunAccess?
Sandbox Settings > Resource Access > Blocked Access > Edit/Add > *pingsender.exe > OK
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

rm22
Posts: 76
Joined: Sun Nov 02, 2014 2:31 am

Re: sandboxes not always deleting contents with Firefox 55?

Post by rm22 » Thu Sep 07, 2017 1:52 am

Yes, it works - Sbie behaves as intended blocking pingsender.exe as you suggested.

It also works to just disable all telemetry in the firefox GUI.

I have been allowing telemetry in my general use firefox sandbox, but block it in my locked down firefox sandboxes (I only allow firefox.exe to run and access the internet over https). But it seems there are issues with pingsender.exe and Sbie even when it is allowed to run so I'm just going to completely disable telemetry for now and see if I have any more issues - I'll report back if I do.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests