AVG + Web Browser -SBIE2101 Object name not found -(C0000022) [SOLVED]

Please post your problem description here

Moderator: Barb@Invincea

whodat
Posts: 14
Joined: Wed Dec 24, 2014 3:07 am

AVG + Web Browser -SBIE2101 Object name not found -(C0000022) [SOLVED]

Post by whodat » Mon May 29, 2017 1:14 am

Chrome.exe – Application Error
Using Windows 10, AVG Version 17.4.3014, SBIE Version 5.19.4, Chrome Version 58.0.3029.110 (64-bit)
Just installed a major AVG Free update (17.4.3014). May be related. When I try to log on through Sandboxie, I get the following messages:
Message from Windows –
Chrome.exe – Application Error: The application was unable to start correctly (0xc0000005)
Message from Sandboxie –
SBIE2101 Object name not found: , error OpenProcess (C000022) access=001FFFF initialized=1

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Mings » Sun Jun 04, 2017 5:28 am

I am using Windows 8.1 with Google Chrome, and have just installed Sandboxie 5.19.5. I am still getting the error message SBIE2101 even after this installation. Any advice?
Mings

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Mon Jun 05, 2017 11:51 am

Hello Mings ,

Did you delete the contents of your Sandbox prior to launching Chrome?
Try creating a new Sandbox to see if the issue follows you there.

Regards,
Barb.-

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Mings » Mon Jun 05, 2017 12:10 pm

Yes, I did delete the contents prior to trying to start Chrome. I have created a new Sandbox but the error message still comes up.
Mings

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Mon Jun 05, 2017 12:33 pm

Hello Mings,

Are you receiving the exact same SBIE2101 Object name not found... message?
Do you have any Antivirus software installed ?
What's your Chrome version? (Does it work fine outside Sandboxie?)
Are you using a Specific website to trigger the issue?
Do you have any extensions enabled?

Can you please provide a PML log? :
Download via: https://technet.microsoft.com/en-us/sys ... nitor.aspx
Launch procmon, reproduce the issue in SBIE, stop procmon (hit the magnifying glass) .
Go to File-->Save and upload the log (you may need to use a free file hosting site as the logs tend to be big).

(Just to double check, Chrome is installed outside Sandboxie, correct?)

Have you tried this?:
viewtopic.php?f=11&t=24217#p127410

Regards,
Barb.-

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Mings » Mon Jun 05, 2017 1:24 pm

The message I am receiving is
SBIE2101 Object name not found: , error OpenProcess (C0000022) access=001FFFFF initialized=1
SBIE2101 Object name not found: , error OpenProcess (C0000022) access=001FFFFF initialized=1
I have AVG Free installed.
Google Chrome version is 58.0.3029.110
I cannot launch Google Chrome Sandboxed; therefore it is not a specific website which is triggering it.
As far as I know, there are no extensions enabled.
This is all getting a bit too technical for me.
Mings

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Mon Jun 05, 2017 1:36 pm

Hi Mings,

If you decide follow the above listed steps for procmon, I will share your PML log with the devs so that they can review it.
You need to download the application, launch it, reproduce your issue in Sandboxie and then go to File --> Save and send us the log.

You can also try disabling Chrome's Sandbox as I posted at the end. The tweak involves an addition to the Chrome's path that disables its own Sandbox.

Otherwise, you may want to try rebooting your computer.

Regards,
Barb.-

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Mings » Mon Jun 05, 2017 2:45 pm

I have saved the log but don't know how to send it to you.
Mings

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Mon Jun 05, 2017 3:22 pm

Hello Mings ,

You will need to use a free file hosting website to upload the log, then send us the download link.

Regards,
Barb.-

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Mings » Mon Jun 05, 2017 4:10 pm

I hope this link will take you to the log:
https://www.dropbox.com/s/xwsf25yn1hv62 ... e.PML?dl=0
Mings

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Mon Jun 05, 2017 4:20 pm

UPDATE:

I installed AVG Free, and started receiving the same error for every browser. I tried disabling the protection, as well as adding the Sandboxie installation folder to the exceptions, it did not help.

Are other browsers working for you? This looks like an AVG related error, not so much google Chrome.
Can you please confirm this is a generalized issue and not Chrome only?

I uninstalled AVG and everything went back to working...Still looking into it.

----------------------------------------- X -----------------------------------------
Thanks Mings,

The devs will review it. We'll update this thread as soon as new info becomes available.

Regards,
Barb.-

WIDEnet
Posts: 4
Joined: Tue Nov 22, 2011 9:10 pm

Re: Chrome - SBIE2101 Object name not found -(C0000022)

Post by WIDEnet » Fri Jun 09, 2017 3:40 pm

I can confirm I have the same issue on Win 8.1 Pro x64 (latest patches) with multiple browsers (Firefox and Chrome), except with a slight twist. I updated AVG Free yesterday (to 17.4.3014) and rebooted, and Firefox 53.0.3 (latest) x64 hasn't worked with Sandboxie since, either 5.18 or 5.20; when attempting to launch it I get an identical SBIE error text as the title of this thread, as well as a dialog box reading "firefox.exe - Application Error: The application was unable to start correctly (0xc000005)." Oddly, Chrome (apparently x64 according to Process Explorer) worked just fine until I rebooted again, and now it won't launch with the same error message. Firefox 53.0.3 x32 has worked just fine throughout, using an identical FF profile as the non-working one—and no plugins except for the latest version of Flash.

I've rebooted twice since the AVG and once since the Sandboxie update, wiped all my sandboxes, disabled AVG, tried starting it with the context menu shortcut and from a sandboxed windows explorer, and using a brand new, default sandbox, all with no success. I can post a procmon log with Firefox, if you'd like, and let me know if there is anything else I can do to help. I've been meaning to get rid of AVG at some point anyway due to its increasingly ethically questionable tactics, and this might just be the time to do it as I'd rather have fast x64 FF and a working Chrome as backup than spammy AVG, and make do with Windows Defender for now which I doubt is all that much less capable in practice.

Also, not sure if this is related, but running Firefox x32 Sandboxed there seems to be significant UI lag that I didn't notice before the AVG/SBIE update; most visibly, when I type text quickly, the displayed text lags a good few hundred ms behind what I've typed. While I've gotten worse UI lag than this if I've had FF open for a long while (weeks) and not cleaned the sandbox, I can never recall this sort of lag with a clean sandbox nor a just-opened copy of FF (mostly x64 recently), and it never happens outside the sandbox including now. Its not a memory leak since I just opened it, and I have 22GB of DDR3-1600 free, and the virtual size and physical ram usages for firefox are within nominal limits in process explorer. If it reoccurs in Firefox x64 when this problem is resolved and I can't solve it, I'll post another thread but figured I'd mention it here in case it was somehow connected given it occurred at the same time—but it could have something to do with my x32 Firefox build.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2675
Joined: Mon Nov 07, 2016 3:10 pm

Re: AVG + Web Browser -SBIE2101 Object name not found -(C0000022)

Post by Barb@Invincea » Fri Jun 09, 2017 3:47 pm

Hello UltimatePhoenix ,

Can you confirm that the issue goes away when you uninstall AVG?

Regards,
Barb.-

WIDEnet
Posts: 4
Joined: Tue Nov 22, 2011 9:10 pm

Re: AVG + Web Browser -SBIE2101 Object name not found -(C0000022)

Post by WIDEnet » Fri Jun 09, 2017 4:09 pm

UltimatePhoenix...that's a name I haven't heard in a long time... Must have created this account ages ago back when I was a kid; how embarrassing. Is it possible for you to change it to WIDEnet?

But I digress, sorry. To answer your question, yes, both FF x64 and Chrome x64 launch and run just fine (and no UI lag, etc) after uninstalling AVG, rebooting the machine and wiping the sandbox. At this point, I'm just going to keep it that way and stick with Windows Defender for now (+ Sandboxie, on-demand tools, etc). Thanks for your help, and if there's anything else I can do to help others without re-installing AVG, let me know.

Mings
Posts: 25
Joined: Sun Jan 19, 2014 1:47 pm
Location: Waterlooville, Hampshire

Re: AVG + Web Browser -SBIE2101 Object name not found -(C0000022)

Post by Mings » Sat Jun 10, 2017 4:48 am

I am using Windows 8.1 and AVG Free. I have just installed Sandboxie 5.20 but am still getting the error message SBIE2101 every time I try to access a Web browser (either Chrome or Internet Explorer). If I want to access another program via a shortcut on the desktop (eg Irfanview or Navigator 4) I can run this sandboxed by right-clicking and then clicking "run sandboxed" without a problem. I certainly do not want to uninstall AVG.
Mings

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests