Certificate Authority incorrect [err 12045] [SOLVED]

Please post your problem description here

Moderator: Barb@Invincea

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Certificate Authority incorrect [err 12045] [SOLVED]

Post by PepC4U2 » Fri Dec 23, 2016 3:59 pm

Sandboxie 5.16 failed to reactivate. Have lifetime license. Sandboxie License Manager message :
The Certificate Authority is invalid or incorrect [err 12045 by 14] .
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Tue Dec 27, 2016 10:44 am

PepC4U2,

Can you try clearing the license and re-entering it ? [Help ---> Register Sandboxie ---> OK ---> Clear License Information]
If all fails, you may want to try reinstalling SBIE.

Please send an email to support@sandboxie.com if you are still unable to activate the product.

Regards,
Barb.-

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Tue Dec 27, 2016 1:04 pm

Hi Barb.
Tried clearing license and re-entering it but that didn't work. Tried reinstalling Sandboxie
5.16 and it installed but failed to activate license.

Also when clicking on ' Check For Updates ' in Sandboxie Control I get this error message.
Update failed: An error occurred while communicating with the Sandboxie Web site.
This has worked in the past. Firewall is set to allow for updating and activation.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Tue Dec 27, 2016 2:36 pm

PepC4U2,

Do you have any AV software that you can disable and try again?
Can you disable the Firewall for testing purposes and see if that works?

Regards,
Barb.-

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Tue Dec 27, 2016 3:10 pm

Barb,

No AV is installed on the system. Had already disabled firewall before testing to make sure that
wasn't the issue. Went back to Sandboxie 5.14 until issues (update and activation) can be resolved.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Tue Dec 27, 2016 3:20 pm

PepC4U2,

We are not seeing any other issues (aside from your post) with the activation.
If you provide your OS and AV versions and how you reproduced the problem, I can test it.

Regards,
Barb.-

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1657
Joined: Fri Jan 17, 2014 5:21 pm
Contact:

Re: Product activation failed

Post by Curt@invincea » Tue Dec 27, 2016 6:03 pm

Sandboxie now uses https for updates, licenses, etc. It looks like you have something blocking https://www.sandboxie.com.

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Wed Dec 28, 2016 2:14 pm

I'm seeing a TCP ack packet attack blocked in TCP at IP 67.227.172.122 on port 443 in firewall filter logs.
Disabled firewall but still can't get Sandboxie update to work or activate license for 5.16 when installed.
Note: OS is Windows XPSP3 and no AV is installed. Don't know of anything else that would be blocking
Sandboxie address.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Wed Dec 28, 2016 2:41 pm

PepC4U2,

You could try disabling the Firewall service, see if that makes a difference:
Run services.msc
Find Windows Firewall...
Right click - Stop
Right click --> Properties
Startup type --> Disabled
Select Apply, then hit OK.

Re-try activating SBIE (reboot if needed).

Regards,
Barb.-

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Thu Dec 29, 2016 12:38 pm

Nothing mentioned so far is working. Unable to activate Sandboxie license and check for updates failed to.
Firewall service was disabled. Currently still have Sandboxie 5.14 installed.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Thu Dec 29, 2016 1:23 pm

PepC4U2,

Any chance there are leftovers from a previous Antivirus installation? Does your router have any firewalls setup, etc etc?

See if you can telnet the IP you provided before. It should return an empty box.
Open cmd.exe and type telnet 67.227.172.122 443

Maybe try to re-enable the firewall and add port 443 to test.
Go to Windows Firewall ---> Exceptions --> Add a port
Add port 443 TCP and see if that works (make sure that "Don't allow exceptions is not checked in the General Tab).
You can also try adding Sandboxie to the programs list.

Regards,
Barb.-

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Thu Dec 29, 2016 3:06 pm

Barb,
No AV has been permanently installed on the real system. Cmd prompt shows an empty box on IP test.
Also during testing starting with Sandboxie 5.10 installed I then installed Sandboxie 5.12
and registered the license. Then I installed Sandboxie 5.14 and again successfully registered
the license. Lastly I installed Sandboxie 5.16 and the registration failed.
The problem seems to be with registering Sandboxie version 5.16.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Thu Dec 29, 2016 3:26 pm

PepC4U2,

As Curt explained, Sandboxie now updates via https (since 5.15.6). We need to figure out what's blocking that on your system.
Please test the firewall as requested, try adding the exceptions and check the router for anything that might be blocking it there.

If you are running anything else while you are trying to perform the activation, let me know and I will test it (so far, I have not been able to reproduce this issue on XP SP3).

Regards,
Barb.-

PepC4U2
Posts: 139
Joined: Wed Sep 18, 2013 3:06 am

Re: Product activation failed

Post by PepC4U2 » Fri Dec 30, 2016 5:25 pm

Barb,
Windows firewall: Checked box for log dropped packets and log successful connections.
Added port 443 in exceptions and added SbieSvc.exe in Add Program...
Added IP address 67.227.172.122 to services in Advanced Settings.

Firewall log shows:
OPEN TCP (IP address- src-ip) 67.227.172.122 (dst-ip) 1102 (src-port) 443 (dst- port)
CLOSE TCP (IP address- src-ip) 67.227.172.122 (dst-ip) 1102 (src-port) 443 (dst- port)
DROP TCP 67.227.172.122 (src-ip) (dst-ip) src-prt 443 dst-port 1102...
Note: Firewall log is edited.

If reading correctly the firewall is dropping packet on destination IP 67.227.172.122 on port 443.
Sandboxie

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2673
Joined: Mon Nov 07, 2016 3:10 pm

Re: Product activation failed

Post by Barb@Invincea » Fri Dec 30, 2016 5:36 pm

PepC4U2,

Here's another idea, please go back to your Firewall, Advanced Tab.
Uncheck your connection (should be listed under Network Connection Settings).
Then, go to Control Panel --> Network connections
Right click on your connection --->Properties --> Advanced
Make sure the firewall is off (if not, please turn it off).
Re-test activating Sandboxie (reboot if needed).

Also, you can try adding all of the executable files (including License.exe) to the Firewall exceptions if all fails.

Regards,
Barb.-

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 15 guests