Steam browser(CEF) - not working.

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
Aleksei Petrov
Posts: 2
Joined: Mon Dec 12, 2016 6:07 pm

Steam browser(CEF) - not working.

Post by Aleksei Petrov » Mon Dec 12, 2016 6:21 pm

Steam browser(CEF) not work after last Steam update in Sandboxie.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2732
Joined: Mon Nov 07, 2016 3:10 pm

Re: Steam browser(CEF) - not working.

Post by Barb@Invincea » Mon Dec 12, 2016 7:06 pm

Hello Aleksei Petrov,

Could you please provide the following info:
OS, SBIE and AV version ?

If you are running Windows 10, can you please make sure to have a default browser other than Edge and re-test ?
If that fails, please try the following:

Right click on your Sandbox --> Sandbox Settings ---> Resource Access --> COM access
Hit Add, and add the following
{3480A401-BDE9-4407-BC02-798A866AC051}
Then, go to Configure --> Reload configuration and try launching Steam Sandboxed again.

Let us know if that works, we are looking into it.

Regards,
Barb.-

Aleksei Petrov
Posts: 2
Joined: Mon Dec 12, 2016 6:07 pm

Re: Steam browser(CEF) - not working.

Post by Aleksei Petrov » Tue Dec 13, 2016 12:00 am

Win 7, SB last beta, KAV 2013

It not helped.

Also i just read Browsers Thread here. So i think it is Chrome problem? since CEF actually Chrome and it not work as well.

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2732
Joined: Mon Nov 07, 2016 3:10 pm

Re: Steam browser(CEF) - not working.

Post by Barb@Invincea » Tue Dec 13, 2016 9:36 am

Hello Aleksei Petrov,

Can you please provide more information regarding the problem that you are experiencing?
Repro steps would be greatly appreciated.

Also, please try disabling your AV and creating a new Sandbox to rule out any other issues.

Regards,
Barb.-

Maart
Posts: 7
Joined: Thu Dec 15, 2016 9:43 am

Re: Steam browser(CEF) - not working.

Post by Maart » Thu Dec 15, 2016 10:09 am

Aleksei Petrov wrote:Steam browser(CEF) not work after last Steam update in Sandboxie.
Chromium Embedded Framework uses own sandbox which interfere with sandboxie sandbox, to disable it start steam.exe witch parameter -no-cef-sandbox
Works for me W7 64-bit SB 5.06

Barb@Invincea
Sandboxie Support
Sandboxie Support
Posts: 2732
Joined: Mon Nov 07, 2016 3:10 pm

Re: Steam browser(CEF) - not working.

Post by Barb@Invincea » Thu Dec 15, 2016 10:59 am

Do you have Steam installed inside SBIE?
What is the issue that you are experiencing, exactly?

Regards,
Barb.-

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: Steam browser(CEF) - not working.

Post by Syrinx » Thu Dec 15, 2016 11:35 am

Maart wrote:
Aleksei Petrov wrote:Steam browser(CEF) not work after last Steam update in Sandboxie.
Chromium Embedded Framework uses own sandbox which interfere with sandboxie sandbox, to disable it start steam.exe witch parameter -no-cef-sandbox
Works for me W7 64-bit SB 5.06
Many thanks for this tip, I can finally browse the store again inside steam on Windows 7 x64 using SBIE 5.16RC. The stemwebhelper actually starts up like it used to!
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

Maart
Posts: 7
Joined: Thu Dec 15, 2016 9:43 am

Re: Steam browser(CEF) - not working.

Post by Maart » Thu Dec 15, 2016 11:41 am

Barb@Invincea wrote:Do you have Steam installed inside SBIE?
What is the issue that you are experiencing, exactly?

Regards,
Barb.-
Yes, when Steam is installed in sandbox only "LIBRARY" tab works, other tabs are blank. Also in-game browser doesn't work.
It is probably same problem Chrome 55+ has.
http://forums.sandboxie.com/phpBB3/view ... 23#p125023

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests