Ever since 5.14, these 30~MB cache files are being created.

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
Special
Posts: 67
Joined: Sat Jun 22, 2013 5:07 pm

Ever since 5.14, these 30~MB cache files are being created.

Post by Special » Mon Oct 03, 2016 7:25 pm

So this all started since v5.14 of SB, I run a lot of portable programs, and they should only be leaving behind a small 1KB sized .ini file, but I've noticed now that when I go to delete my Sandboxes, whats left inside them are files in the range of 16-50~MB called iconcache_16, iconcache_32, iconcache_48, ect. they are located in the;

C:\Users\NAME\AppData\Local\Microsoft\Windows\Explorer folder.

It's a Windows thing obviously (Win10 here btw) but why since 5.14 are these being created, I don't like the fact that if I want to run some tiny 500KB program that leaves just a small 1KB ini files behind that there needs to be 50 or more MB's being written.

Any ideas?

Syrinx
Sandboxie Guru
Sandboxie Guru
Posts: 621
Joined: Fri Nov 13, 2015 4:11 pm

Re: Ever since 5.14, these 30~MB cache files are being creat

Post by Syrinx » Mon Oct 03, 2016 8:13 pm

I can't say why you are seeing a change like this but a workaround might be to add
%Local AppData%\Microsoft\Windows\Explorer
under Sandbox Settings > Resource Access > File Access > Read-Only Access
so that it can't create the files in the sandbox. Might cause issues with thumbnails and pics inside though.
http://goo.gl/p8qFCf
https://www.youtube.com/watch?v=vIxWgVOCexU

Special
Posts: 67
Joined: Sat Jun 22, 2013 5:07 pm

Re: Ever since 5.14, these 30~MB cache files are being creat

Post by Special » Tue Oct 04, 2016 3:22 pm

I did what you suggested and it seemed to have worked, I will need to play around with this though as I'm not saying this is the way to go or that everything will be stable.

Would like to hear from Curt thought on this.

Guest10
Posts: 5133
Joined: Sun Apr 27, 2008 5:24 pm
Location: Ohio, USA

Re: Ever since 5.14, these 30~MB cache files are being creat

Post by Guest10 » Wed Oct 05, 2016 1:14 pm

Before I updated to the latest Windows Anniversary Update, some of my files in that folder were large enough to cause me File Migration issues, too.
I added a Read-Only setting to my GlobalSettings section at that time and had no difficulties with it.

[GlobalSettings]

...
...
...
ReadFilePath=%Local AppData%\Microsoft\Windows\Explorer\


After the Windows update, the files in that folder haven't grown large enough (yet) to actually need the setting, but I chose to leave it there anyway.
Paul
Win 10 Home 64-bit (w/admin rights) - Zone Alarm Pro Firewall, MalwareBytes Premium A/V, Firefox, Thunderbird
Sandboxie user since March 2007

Curt@invincea
Sandboxie Lead Developer
Sandboxie Lead Developer
Posts: 1657
Joined: Fri Jan 17, 2014 5:21 pm
Contact:

Re: Ever since 5.14, these 30~MB cache files are being creat

Post by Curt@invincea » Wed Oct 05, 2016 7:02 pm

I know of no changes that would account for this.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 12 guests