Page 1 of 1

Very odd (-1) issue with DVD Drive

Posted: Sun Aug 28, 2016 12:22 am
by Syrinx
This situation certainly isn't normal but it was one of the first "SBIE2204 Cannot start sandboxed service RpcSs (-1)" I've been able to reproduce on a Windows 7 machine. I know you dealt with and managed to fix most of them when Windows 10 came out and it was a larger problem but it was highly annoying in this case.

Basically, I had a DVD that was scratched (or otherwise messed up-I'm not exactly sure why it isn't working yet) so I wanted to use software within in a VM to attempt recovery and avoid installing said software on my real system for a one shot deal...

So, I used a VM (VMWare Workstation 11.1.4) and attached the physical DVD drive to attempt using a software recovery solution.
While the VM and software within was active, I couldn't launch anything sandboxed on my REAL machine or I'd get the error shown above after quite a lengthy delay, I tried a couple different programs in different boxes all with the same result....

However the instant I closed out the VM and re-tired SBIE it resumed normal operation without any further errors.

One thing I (think I) was able to gather [though I can't be 100% about yet] is that this was involving the vmware-usbarbitrator service (my dvd isn't attached via usb but it wouldn't detect or access it without that service being active first...weird in its own way!]