Using a network shared folder as Sandboxie container

Please post your problem description here

Moderator: Barb@Invincea

Post Reply
frusern
Posts: 2
Joined: Mon Nov 14, 2011 12:44 pm

Using a network shared folder as Sandboxie container

Post by frusern » Tue Nov 15, 2011 8:17 am

Dear reader,

I've tried Sandboxie 3.60 x64 in a Vista Ultimate x64 SP2 and x86 in XP Professional x86 SP3,
When I've set the container to a ram drive (ImDisk Virtual Disk Driver) or memory stick or HDD everything works great.
But when I've tried to set it to a network path, there were some issues in Vista x64.
The issue:
1. Set container path to e.g. \\test\sharedfolder
2. Create new default sandbox e.g. abc
3. Right click on Notepad, run sandboxed, in sandbox abc
4. In sandboxed notepad chose File->save, it takes a while, pick e.g. desktop, or d:\test\test.txt
5. Repeat file->save but when choosing previous drive, it's no longer accessible,
windows file open dialog pops up a message box with
title [#] Location is not available [#] and message D:\ is not accessible The request is not supported.

If I look inside the sandbox folder \\test\sharedfolder\abc I can see the file, folder created.
If I close notepad, reopen it in the same sandbox abc, from the beginning I can't access the drive where previously tried to save.

User has administrator rights and UAC in enabled in Vista.
I have no problem in writing/reading to the network path, it's a linux, samba, access is root, no password with full rights.

I've tried but didn't succeed to solve the issue by doing the following:
a. Create a network drive using windows from interface or in cmd using subst or net use, and set container to that folder
b. Install and use Virtual Disk Manager (http://www.virtualdisk.net/), a tool that creates a drive from one or more paths including network share,
and set container to that folder. This tool it's using a driver to achieve that, so I thought it would be different from Vista approach.
c. Uncheck Drop Rights in Sandbox Settings and run notepad with UAC rights when prompted by sandboxie.
d. Check use Experimental Protection (x64), Check/Uncheck Drop Rights, restart, run notepad with UAC rights when prompted by sandboxie.

I'm not sure if it's a Vista problem/setting or sandboxie problem/setting. All settings are default in Vista and default or custom in Sandboxie.

In XP x86 Professional no issue.

Thank you for reading this, and thank you Ronen Tzur for creating this wonderful software.

frusern
Posts: 2
Joined: Mon Nov 14, 2011 12:44 pm

Post by frusern » Tue Nov 15, 2011 8:56 am

It seems there's an issue with the samba share or share configuration, if I set the container to a XP x86 share (use simple file sharing unchecked), no issue,
but doing this way I can't rename folders and files that were created with a sandboxed notepad. The error is Destination folder access denied.
I can create folders, delete them, create files, delete them but can't rename them.
If I set the container to a Vista x64 share, open notepad, choose to create folder or file, file open/save dialog freezes.

As I don't know what's happening behind the scene, how Sandboxie works, I hope somebody will give a hint if
it's even possible to set the container to a network shared folder.

tzuk
Sandboxie Founder
Sandboxie Founder
Posts: 16076
Joined: Tue Jun 22, 2004 12:57 pm

Post by tzuk » Tue Nov 15, 2011 4:50 pm

I'm sorry but I don't think you can set the sandbox folder on a network share and have it work flawlessly. I'm actually surprised to hear you got it to sort-of work on your XP x86 configuration.

All filesystems have their quirks but at least with FAT32 and NTFS there are only a few quirks, and you get the exact same quirks on every system and every version of Windows. With network shares it's much less predictable, many SMB implementations behave a bit differently to each other, and to how a local would behave.
tzuk

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 8 guests