Trust No Program

Memory use

Please post your problem description here

Memory use

Postby Unknown_User_815 » Sun Jul 15, 2007 4:25 am

I recently installed Ver 3.0 after using 2.86 with great success.
After launching IE sandboxed - my computer immediately slowed to a crawl.
Checking Task Manager, I noticed Sandboxie using over 60mb of memory.
Launching a second program sandboxed and memory usage jumped to 80mb+ and I had to reboot.
Reinstalled Ver 2.86 and Sandboxie only used 5 - 6 mb on my system under the same conditions.
Is this typical with Ver 3.0 or some type of conflict with my system?
Love to be able to use some of the new features - any suggestions?


Thanks for any help
Unknown_User_815
 
Posts: 0
Joined: Thu Jan 01, 1970 1:00 am

Postby street011 » Sun Jul 15, 2007 11:17 am

sandboxie service is using a bit of ram indeed... it's on 30 now while sandboxing some explorer (40mb) firefox (190mb) and msn (36mb) so the other sandboxie related processes are all under 1.6mb so i don't think thats a lot of ram being used by sandboxie...

your computer shouldn't slow down if a process takes up 60 mb of ram... unless your computer is as old as my mum...
street011
 
Posts: 410
Joined: Tue Jan 16, 2007 8:08 pm

Postby tzuk » Sun Jul 15, 2007 1:14 pm

Probably there's a conflict with some other program. db1090 could you try disabling/uninstalling some of your other programs, and see which one, when re-activated, causes Sandboxie 3 to misbehave?
tzuk
tzuk
Site Admin
 
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm

Postby SnDPhoenix » Sun Jul 15, 2007 1:21 pm

I think its because of the fact that Sbie 3.00 is much more strict now, for example Sandboxed applications can't communicate with windows outside the sandbox anymore, and i think (for you) that is whats causing the problem, something in ie is trying to access an unsandboxed window/app but isnt able to (maybe a plugin or toolbar), which causes it to conflict which in turn causes the memory leak your seeing. So if you could find the blocked resource (assuming there is one), you could allow it and then no more memory leak.
Windows 7 SP1 x64, Sandboxie v3.70 x64 with Experimental Protection, GnuPG, OTR (Off-The-Record), Sticky Password, My Brain.
SnDPhoenix
 
Posts: 2690
Joined: Tue Dec 26, 2006 11:44 pm
Location: West Florida

Postby Oneder » Sun Jul 15, 2007 3:58 pm

Vista Ultimate mem usage atm:

Sandboxed Firefox = 33 meg

SandboxieRpcSs.exe = 2.59 meg

SandboxieDcomLaunch.exe = 2.4 meg

Control.exe = 1.85 meg

SbieSvc.exe = 604 kb
Hunting the Hunter!
Oneder
 
Posts: 364
Joined: Tue Aug 30, 2005 1:19 pm
Location: Perth,West Oz

Postby Unknown_User_815 » Sun Jul 15, 2007 8:02 pm

Thanks for all the suggestions - I will experiment some and let you know what I find.

My computer is getting a little gray around the gills (3yrs) but I think there is more to it as

I still have plenty of free ram when this happens.
Unknown_User_815
 
Posts: 0
Joined: Thu Jan 01, 1970 1:00 am

Postby Unknown_User_815 » Mon Jul 16, 2007 3:09 pm

Okay - I did some testing on my system. Uninstalled all plugin's, security app's (AV,firewall etc)
and came up with same result , slowdown and high memory usage.
I did find, however, if I completely uninstall Sanboxie V2.86,
and do a fresh install of V3.0 the problem clears.
Repeating the cycle of installing V2.86 then upgrading to V3.0 reproduces the issue.

V3.0 after a fresh "non upgrade" install

control 3,476K
SandboxieDcomlaunch 2,248K
SandboxieRpcSs.exe 5,732K
SbieSvc.exe 2,012K

Working great now with no noticable slowdowns or memory usage.
Unknown_User_815
 
Posts: 0
Joined: Thu Jan 01, 1970 1:00 am

Postby SnDPhoenix » Mon Jul 16, 2007 3:57 pm

So if you install 3.0 over 2.86, then you get the memory leaks and slowdowns, but if you uninstall 2.86 and then install 3.0 fresh, you dont get the slowdowns or memory leaks? Hmm, i wonder if anyone else can confirm that?
Windows 7 SP1 x64, Sandboxie v3.70 x64 with Experimental Protection, GnuPG, OTR (Off-The-Record), Sticky Password, My Brain.
SnDPhoenix
 
Posts: 2690
Joined: Tue Dec 26, 2006 11:44 pm
Location: West Florida

Postby laszlo » Mon Jul 16, 2007 4:12 pm

SnDPhoenix wrote:So if you install 3.0 over 2.86, then you get the memory leaks and slowdowns, but if you uninstall 2.86 and then install 3.0 fresh, you dont get the slowdowns or memory leaks? Hmm, i wonder if anyone else can confirm that?

I can't. I have a freshly installed 3.0, and I've seen SbieSvc.exe use more than 50MB of memory, whereas 2.86 always stayed around or below 5MB. I was noticing this with some of the betas, too. The problem is just that I don't see a pattern yet, and it happens very rarely for me, which makes it kind of hard to pinpoint. Normally, memory usage of 3.0 is roughly in the 2.86 range for me.

All I can say so far is that on my machine it doesn't seem to be directly related to the memory usage of sandboxed programs (my sandboxed programs often use more than 1GB of memory without triggering greater memory usage in SbieSvc.exe).

Furthermore, though I didn't quantitatively measure the performance of sandboxed programs when this happened, I got the impression that they were running slightly slower than usual. That's how I noticed it when it started. The rest of the system was unaffected.
laszlo
 
Posts: 32
Joined: Fri Jun 01, 2007 1:59 pm

Postby tzuk » Tue Jul 17, 2007 12:46 pm

I had a similar experience, laszlo. Very rarely, once in a couple of weeks perhaps, I see SbieSvc crash. So far I haven't been able to reproduce this problem "on demand", so I wasn't able to investigate it. Eventually some hint will come up ...
tzuk
tzuk
Site Admin
 
Posts: 16076
Joined: Tue Jun 22, 2004 5:57 pm


Return to Problem Reports

Who is online

Users browsing this forum: No registered users and 5 guests